Closed Bug 999206 Opened 6 years ago Closed 6 years ago

[B2G][Tarako][Dialer]User ending outgoing call displays inconsistent messaging and behavior while intermittently generating unexpected tones

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3 unaffected, b2g-v1.3T affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- affected

People

(Reporter: mclemmons, Unassigned)

References

()

Details

(Whiteboard: [tarako-exploratory])

Attachments

(2 files)

User makes a valid outgoing call. However, user taps the red hangup button within a second of selecting the green call button - which is realistic if user suspects they dialed a wrong number and doesn't want the call to go through. User witnesses the Call Ended message on device. However, the screen slides upwardly and becomes black for several seconds. Afterward, the screen message displays 'The number is currently busy. Please try again' and an OK button. This is concerning and confusing since the previous screen mentioned the call ended. On occasion, a busy tone can be heard after some testing attempts (2 out of 10 attempts).

Repro Steps
1) Updated Tarako to BuildID: 20140421014001
2) Tap Dialer App and enter valid phone number then select Green call button
3) Immediately tap the red call cancel button 


Actual:
User witnesses the Call Ended message on device. However, the screen slides upwardly and becomes black for several seconds. Afterward, the screen message displays 'The number is currently busy. Please try again' and an OK button.

Expected:
User witnesses the Call Ended message on device. Call ends and user is returned to the Dialer App home page which displays the phone pad.

Environmental Variables:
Device: Tarako 1.3T MOZ
BuildID: 20140421014001
Gaia: 68e072af2348c46fbff8a35d99ff10caeab16880
Gecko: a8cc1aaec6a3
Version: 28.1
Firmware Version: sp6821a_gonk4.0_user.pac 

Notes:
Repro frequency: (10/10, 100% - busy tone audible 2/10, 20%)
See attached: (firewatch, video clip= https://www.youtube.com/watch?v=IoKrraqKTWA, logcat)
This issue does not reproduce on 1.3 Buri. Following the STR from Comment 0, user witnesses the call ended messaging and returns to the dialer keypad without any other messaging seen or tones heard (10 attempts, no repros of behavior from Comment 0). 

Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140421024003
Gaia: 69dcf31d3a95765a7d7c54a14acf6adca23f351d
Gecko: b43a6c8e467d
Version: 28.0
Firmware version: v1.2-device.cfg
Weird.  I can't reproduce this issue.  Maybe it's a timing thing?
Does this reproduce on trunk?
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #4)
> Does this reproduce on trunk?

Did NOT reproduce on master build with Buri. Call correctly ended and returned to dial pad screen. Repro rate: 0 out of 10 attempts.

Tested on:
Device: Buri MOZ
BuildID: 20140425040203
Gaia: facd91d31db983a60c7f1035ca01b727c7a1de65
Gecko: 2b02d933c39a
Version: 31.0a1
Firmware Version: v1.2-device.cfg
Keywords: qawanted
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #3)
> Weird.  I can't reproduce this issue.  Maybe it's a timing thing?

Can we clarify the STR here & reproduction rate a bit better?
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #6)
> (In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from
> comment #3)
> > Weird.  I can't reproduce this issue.  Maybe it's a timing thing?
> 
> Can we clarify the STR here & reproduction rate a bit better?

Attempted repro following the STR from Comment 0 and reviewing the video and unable to repro on latest 1.3T. Attempted 75 times and unable to repro. Attempted modifications to STR in steps and was unable to reproduce on an additional 25 attempts. Expected behavior of Call Ended and return to the Dialer Pad screen occurred. 

Environmental Variables:
Device: Tarako 1.3T MOZ
BuildID: 20140428014001
Gaia: 8895b180ed636069473703d0e7b73086989601ce
Gecko: 7caf4b5abfce
Version: 28.1
Firmware Version: sp6821a_gonk4.0_user.pac 

Attempted repro following the STR from Comment 0 on Tarako build originally reported (4-21-2014) and could not repro after 25 attempts. Expected behavior of Call Ended and return to the Dialer Pad screen occurred. 

Environmental Variables:
Device: Tarako 1.3T MOZ
BuildID: 20140421014001
Gaia: 68e072af2348c46fbff8a35d99ff10caeab16880
Gecko: a8cc1aaec6a3
Version: 28.1
Firmware Version: sp6821a_gonk4.0_user.pac
Keywords: qawanted
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.