Closed Bug 999224 Opened 6 years ago Closed 4 years ago

[Tarako] Accelerometer not working in 3rd party apps

Categories

(Firefox OS Graveyard :: Vendcom, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3T affected)

RESOLVED WONTFIX
Tracking Status
b2g-v1.3T --- affected

People

(Reporter: adora, Unassigned)

Details

(Whiteboard: [tarako-bug-bash-1.3T])

Build Information

Device: Tarako
BuildID   20140415004002
Version   28.1


Description
App rotation works correctly as tested in the Gallery app, but apps themselves aren't able to use accelerometer data.


Steps to Reproduce

1. Install Orbland Labyrinth Free from Marketplace: https://marketplace.firefox.com/app/orbland-free?src=search
2. Launch game and rotate device

Expected Results
Marble moves 

Actual Results
Marble doesn't move

Other Notes
Also tested on keon v1.1 and v1.3, which works but the controls seem to be reversed.  

Bug duplicated with simpler app Candle (which is also reversed): https://marketplace.firefox.com/app/candle?src=search

Reproduction Frequency: 100%
This is interesting: 
http://people.mozilla.org/~nhirata/html_tp/accel_bug615597.html doesn't seem to work on the device.
http://people.mozilla.org/~nhirata/html_tp/ball.html does seem to work on the device (with some weird orientation issue... I think the up/down is reversed I have to take a closer look).

Could you relay the information to the developers of the apps?
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #1)
> This is interesting: 
> http://people.mozilla.org/~nhirata/html_tp/accel_bug615597.html doesn't seem
> to work on the device.
> http://people.mozilla.org/~nhirata/html_tp/ball.html does seem to work on
> the device (with some weird orientation issue... I think the up/down is
> reversed I have to take a closer look).
> 
> Could you relay the information to the developers of the apps?

I don't think this is an app bug - it's more likely a vendor problem with the orientation sensor. There's a similar bug on file for this for cut the rope as well.
Can we test this on 1.3 on a production device as a point of comparison?
Keywords: qawanted
Tested on 1.3 Buri, and the issue where controls are reversed reproduces; As in, the marble moves against gravity.

Device: Buri 1.3 MOZ
BuildID: 20140423024002
Gaia: fb2b8e25e8095a5db49b5eb68c74b49f180605d4
Gecko: da2500909f91
Version: 28.0
Firmware Version: v1.2-device.cfg
Keywords: qawanted
My money is on that this is a vendor problem. 

Sam - Do you have any ideas why this is happening?
Component: Gaia → Vendcom
Flags: needinfo?(sam.hua)
Hi Jason,

I will test accelermeter sensor
Flags: needinfo?(sam.hua)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.