Closed Bug 999284 Opened 6 years ago Closed 6 years ago

Firefox 29.0 printing blank page instead of PDF

Categories

(Firefox :: PDF Viewer, defect, P3)

29 Branch
x86_64
Windows 8.1
defect

Tracking

()

RESOLVED DUPLICATE of bug 1003707
Tracking Status
firefox29 --- affected

People

(Reporter: gargoyles, Unassigned)

References

()

Details

(Whiteboard: [pdfjs-c-integration][pdfjs-d-printing])

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140417185217

Steps to reproduce:

On my Windows 8.1 machine I opened several one page PDFs directly in Firefox 29.0 - using Firefox's PF viewer, not an add-on and not a 3rd party program (i.e. Adobe Reader). 


Actual results:

The PDFs displayed correctly, and saved correctly as I verified later, but would repeatedly only print a completely blank page even after going back to the original site and re-opening them several times. After saving the files and opening them in Adobe Acrobat, they printed just fine.


Expected results:

The PDF files should have printed directly from Firefox without any issues.
(a) I used both the printer icon on the upper right hand side of the PDF viewer UI, and the File -> Print command.
(b) I linked to just one of the files that would not print, but as far as I can tell no PDFs will print on this system.
(c) Thank you!
Status: UNCONFIRMED → NEW
Component: Untriaged → PDF Viewer
Ever confirmed: true
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
Build ID: 20140421221237

Confirmed on Windows 7 SP1 x64 using Firefox 29's built-in PDF reader on another web site. Can't give a URL as it's for internal use, but the symptoms are the same. The OP's linked PDF is also blank on this system. PDF printing worked with Firefox 28.0.
Priority: -- → P3
Whiteboard: [pdfjs-c-integration][pdfjs-d-printing]
I just had a chat with a user who tested this in a new profile and still had a blank page when printing PDF's. Printing from Adobe works just fine. Let's get this on the radar for a possible 29.0.1 as this looks bad.
I guess it is a regression of 29 and 30 & 31 are also affected.
Anyway, tracking on the advice of Tyler.
dup of 1003707 ?
Sylvestre, is 31 and 32 really affected or it's just an assumption based on 29 and 30 regression?
Flags: needinfo?(sledru)
It was just an assumption. Sorry, I jumped to quickly on this bug.
Making it a duplicate of bug 1003707 based on comment 2 and similarity in STR. Also the latter has regression window specified.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1003707
You need to log in before you can comment on or make changes to this bug.