Fix FindInReadable calls in ApplicationReputation

RESOLVED FIXED in Firefox 30

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mmc, Assigned: mmc)

Tracking

(Blocks 1 bug)

Trunk
mozilla31
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox30 fixed, firefox31 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

In practice, binaries appear in only one list so FindInReadable on the table names is equivalent to equality checking.

However, it's still a bug.
Assignee: nobody → mmc
Status: NEW → ASSIGNED
Comment on attachment 8410300 [details] [diff] [review]
Fix FindInReadable calls in ApplicationReputation (

Review of attachment 8410300 [details] [diff] [review]:
-----------------------------------------------------------------

Previous comment should have been: URLs typically appear only on one list.
Attachment #8410300 - Flags: review?(gpascutto)
Comment on attachment 8410300 [details] [diff] [review]
Fix FindInReadable calls in ApplicationReputation (

Review of attachment 8410300 [details] [diff] [review]:
-----------------------------------------------------------------

This may be testable? Construct update that inserts entry in both block and allow DB. Check for expected behavior on a double hit. That seems like it might be useful outside this bug as well?
Attachment #8410300 - Flags: review?(gpascutto) → review+
(In reply to Gian-Carlo Pascutto [:gcp] from comment #3)
> Comment on attachment 8410300 [details] [diff] [review]
> Fix FindInReadable calls in ApplicationReputation (
> 
> Review of attachment 8410300 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> This may be testable? Construct update that inserts entry in both block and
> allow DB. Check for expected behavior on a double hit. That seems like it
> might be useful outside this bug as well?

Good idea -- it'll take a little time to construct due to the binary nature of the test data and I'm gone later this week, so I filed bug 662819 for this.
https://hg.mozilla.org/mozilla-central/rev/ec50db58f17b
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
Comment on attachment 8410300 [details] [diff] [review]
Fix FindInReadable calls in ApplicationReputation (

[Approval Request Comment]
Bug caused by (feature/regressing bug #): initial implementation
User impact if declined: Not much risk since the string comparison is most likely to be an equality check, but this is a bug (see comment 1)
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): very low risk
String or IDL/UUID changes made by this patch: none
Attachment #8410300 - Flags: approval-mozilla-aurora?
Attachment #8410300 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.