Closed Bug 999559 Opened 10 years ago Closed 10 years ago

Rename IonFrameIterator to JitFrameIterator

Categories

(Core :: JavaScript Engine: JIT, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla31

People

(Reporter: jandem, Assigned: jandem)

Details

Attachments

(2 files)

      No description provided.
Attachment #8410403 - Flags: review?(shu)
Comment on attachment 8410403 [details] [diff] [review]
Part 1 - Rename IonFrameIterator

Review of attachment 8410403 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/jit/Bailouts.h
@@ +13,1 @@
>  #include "jit/IonFrames.h"

I'll switch the order of these includes.
Attachment #8410404 - Flags: review?(luke) → review+
Comment on attachment 8410403 [details] [diff] [review]
Part 1 - Rename IonFrameIterator

Review of attachment 8410403 [details] [diff] [review]:
-----------------------------------------------------------------

Somewhat related: there's inconsistent naming between jitTop and ionTop. I never really liked jitTop, since it's for when we reenter the VM from Ion, never Baseline.
Attachment #8410403 - Flags: review?(shu) → review+
Comment on attachment 8410403 [details] [diff] [review]
Part 1 - Rename IonFrameIterator

Review of attachment 8410403 [details] [diff] [review]:
-----------------------------------------------------------------

BTW, you will need to rebase this if I manage to push the debug mode OSR patches before you push this.
https://hg.mozilla.org/integration/mozilla-inbound/rev/90c23195ebb3
https://hg.mozilla.org/integration/mozilla-inbound/rev/16d11bb0d2fc

(In reply to Shu-yu Guo [:shu] from comment #3)
> Somewhat related: there's inconsistent naming between jitTop and ionTop. I
> never really liked jitTop, since it's for when we reenter the VM from Ion,
> never Baseline.

It's also used when we leave Baseline code, we need it whenever we create a JitFrameIterator for a JitActivation.

(In reply to Shu-yu Guo [:shu] from comment #4)
> BTW, you will need to rebase this if I manage to push the debug mode OSR
> patches before you push this.

Yeah, I'm sorry for breaking your patches. A search-and-replace + check-if-it-compiles should be sufficient though. The problem with these changes is that you're always going to break some patches :( But keeping the Ion* prefix for something that's no longer Ion-only annoys me every time I see it, so I really want to do some of these every week.
(In reply to Jan de Mooij [:jandem] from comment #5)
> https://hg.mozilla.org/integration/mozilla-inbound/rev/90c23195ebb3
> https://hg.mozilla.org/integration/mozilla-inbound/rev/16d11bb0d2fc
> 
> (In reply to Shu-yu Guo [:shu] from comment #3)
> > Somewhat related: there's inconsistent naming between jitTop and ionTop. I
> > never really liked jitTop, since it's for when we reenter the VM from Ion,
> > never Baseline.
> 
> It's also used when we leave Baseline code, we need it whenever we create a
> JitFrameIterator for a JitActivation.
> 

Oh duh, of course exit frames are needed in both. Let's rename the remaining cases of ionTop to jitTop then.
https://hg.mozilla.org/mozilla-central/rev/90c23195ebb3
https://hg.mozilla.org/mozilla-central/rev/16d11bb0d2fc
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
You need to log in before you can comment on or make changes to this bug.