Closed Bug 999631 Opened 6 years ago Closed 6 years ago

Mulet fails at package step

Categories

(Core :: General, defect, blocker)

defect
Not set
blocker

Tracking

()

RESOLVED FIXED
mozilla32

People

(Reporter: gerard-majax, Assigned: ochameau)

References

Details

(Whiteboard: [systemsfe])

Attachments

(1 file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=38230377&tree=Fig

resource://gre/modules/services-sync/util.js
resource://gre/modules/services/datareporting/policy.jsm
resource://gre/modules/services/datareporting/sessions.jsm
resource://gre/modules/services/healthreport/healthreporter.jsm
resource://gre/modules/services/healthreport/profile.jsm
resource://gre/modules/services/healthreport/providers.jsm
resource://gre/modules/services/metrics/dataprovider.jsm
resource://gre/modules/services/metrics/providermanager.jsm
resource://gre/modules/services/metrics/storage.jsm
resource://gre/modules/sqlite/sqlite_internal.js
resource://gre/modules/vtt.jsm
resource://gre/modules/workers/lz4.js
resource://gre/modules/workers/lz4_internal.js
resource://gre/modules/workers/require.js
*************************
A coding exception was thrown and uncaught in a Task.

Full message: TypeError: invalid path component
Full stack: join@resource://gre/modules/osfile/ospath_unix.jsm:87:7
task_DI_initializePublicDownloadList@resource://gre/modules/DownloadIntegration.jsm:212:1
TaskImpl_run@resource://gre/modules/Task.jsm:298:1
TaskImpl@resource://gre/modules/Task.jsm:247:3
createAsyncFunction/asyncFunction@resource://gre/modules/Task.jsm:224:7
Task_spawn@resource://gre/modules/Task.jsm:139:5
this.DownloadIntegration.initializePublicDownloadList@resource://gre/modules/DownloadIntegration.jsm:258:1
this.Downloads.getList/this._promiseListsInitialized<@resource://gre/modules/Downloads.jsm:177:11
TaskImpl_run@resource://gre/modules/Task.jsm:298:1
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:863:11
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:742:7

*************************
Traceback (most recent call last):
  File "/builds/slave/fig-lx-00000000000000000000000/build/toolkit/mozapps/installer/packager.py", line 401, in <module>
    main()
  File "/builds/slave/fig-lx-00000000000000000000000/build/toolkit/mozapps/installer/packager.py", line 393, in main
    args.source, gre_path, base)
  File "/builds/slave/fig-lx-00000000000000000000000/build/toolkit/mozapps/installer/packager.py", line 161, in precompile_cache
    jar = JarReader(cache)
  File "/builds/slave/fig-lx-00000000000000000000000/build/python/mozbuild/mozpack/mozjar.py", line 341, in __init__
    data = open(file, 'rb').read()
IOError: [Errno 2] No such file or directory: '/tmp/tmp9r2CVn.zip'
make[3]: *** [stage-package] Error 1
make[3]: Leaving directory `/builds/slave/fig-lx-00000000000000000000000/build/obj-firefox/browser/installer'
make[2]: *** [make-package] Error 2
make[2]: Leaving directory `/builds/slave/fig-lx-00000000000000000000000/build/obj-firefox/browser/installer'
make[1]: Leaving directory `/builds/slave/fig-lx-00000000000000000000000/build/obj-firefox/browser/installer'
make[1]: *** [default] Error 2
make: *** [package] Error 2

This is a recent regression, latest push to Fig on Apr 17 was okay.
OS: Linux → All
Bug 988880 introduced that exception as b2g runtimes no longer generate startupcache...
Depends on: 988880
Bug 988880's patch is quite brutal and hidden in cpp file.
That doesn't let a chance to prevent executing packager.py's code
about startup cache precompilation.
Here I'm introducing a dedicated flag, to let a chance to any code
to act accordingly, without just using MOZ_B2G everywhere and loosing
the information that we are explicitely disabling startup code somewhere in cpp code!
Attachment #8410952 - Flags: review?(mshal)
Comment on attachment 8410952 [details] [diff] [review]
Disable startup cache via a dedicated flag

Looks good to me. Any idea why the change to packager.py wasn't required for bug 988880?
Attachment #8410952 - Flags: review?(mshal) → review+
Whiteboard: [systemsfe]
When will this land?
Flags: needinfo?(poirot.alex)
(In reply to Michael Shal [:mshal] from comment #3)
> Comment on attachment 8410952 [details] [diff] [review]
> Disable startup cache via a dedicated flag
> 
> Looks good to me. Any idea why the change to packager.py wasn't required for
> bug 988880?

That's because b2g device/desktop uses jar whereas firefox use omnijar, and this particular packager.py code is only trigerred when using omnijar. (Don't ask me the actual difference between both, I have no idea what differs)

(In reply to Alexandre LISSY :gerard-majax from comment #4)
> When will this land?

Once try is green:
  https://tbpl.mozilla.org/?tree=Try&rev=646d7103efb1
Assignee: lissyx+mozillians → poirot.alex
Flags: needinfo?(poirot.alex)
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/d1da7f04c109
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
You need to log in before you can comment on or make changes to this bug.