Bad URL Alert halts File Downloads

RESOLVED DUPLICATE of bug 74331

Status

defect
RESOLVED DUPLICATE of bug 74331
18 years ago
15 years ago

People

(Reporter: amorton, Assigned: neeti)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001091303

While trying to download a 25MB file over a modem (ARRRGHHH!!!!) I was browsing
in the forground trying to find a website. In the process I put in a bad
domainname and the alert poped up to notify me of it. I ignored it and went to
another window, when I looked at my download it had "hung"  so I tried to
restart it. No go then I dismissed the alert and tried again. No problems. 

The short of it: alerts halt downloads.
One thing I didn't check was if it mattered if the download was spawned from the
window that the Alert is attached to...

Reproducible: Always
Steps to Reproduce:
1. Start downloading a file over HTTP
2. In a browser window open "notarealsite.foo"
3. Examine the download window, once the buffered data is clear it will be frozen.
4. Dismiss the alert and the download will continue

Actual Results:  It's okay but your download is delayed by n minutes.

Expected Results:  The download should continue regardless of alerts

Comment 1

18 years ago
.
Assignee: asa → neeti
Component: Browser-General → Networking
QA Contact: doronr → benc

*** This bug has been marked as a duplicate of 74331 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
Component: Networking → Download Manager
QA Contact: benc → nobody
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.