Closed Bug 999716 Opened 6 years ago Closed 6 years ago

[Camera][Open_C] Viewfinder corruption appears after recording a video and switching back to camera mode

Categories

(Firefox OS Graveyard :: Vendcom, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 affected)

RESOLVED DUPLICATE of bug 1007832
Tracking Status
b2g-v2.0 --- affected

People

(Reporter: astole, Unassigned)

References

()

Details

(Whiteboard: [POVB])

Attachments

(2 files)

Attached file logcat
After recording a video and switching back to camera mode there is a graphical issue (looks like noise) at the bottom of the screen. The issue is not there when switching back to video mode

Repro Steps:
1) Update a Open_C/Flame to BuildID: 20140422040203
2) Launch camera app
3) Switch to video mode and record a video
4) Switch back to camera mode

Actual:
There is a graphical issue that covers the bottom portion of the screen

Expected:
There is no graphical issue

2.0 Environmental Variables:
Device: Open_C 2.0 MOZ
BuildID: 20140422040203
Gaia: f0463704888881b8ed1619e8d4b0d851b0e0311b
Gecko: 1d0496e30feb
Version: 31.0a1
Firmware Version: V1.2-device.cfg

Repro frequency: 3/3, 100%
See attached: Video, logcat
This issue does not occur on the latest Master build on Buri.
Does this happen on a 1.4 Open C build?
Keywords: qawanted
Duplicate of this bug: 1004003
With bug 1000567/bug 985481 fixed, the Open_C running b2g30/v1.4 shows corruption of the bottom of the viewfinder.

STR:
1. open the camera app
2. switch to video mode
3. record a short video (e.g. ~5 seconds -- exact length shouldn't matter)
4. switch back to picture mode

Expected result: normal viewfinder

Observed result: bottom ~20% of the viewfinder shows some kind of corruption; the viewfinder is visible through the corruption, but is very noisy.

Will be adding an attachment shortly.

Build:
- gecko: b2g30_v1_4:b723d784febf
- gaia: v1.4:d23e479e8a4ce0bc620acb2d7e2f82801aa4d0ea
This doesn't happen when just switching modes: it is required to start and stop recording a video.

If you press the Home button and return to the Camera app, the corruption is gone.
Confirmed that this exists on b2g-inbound as well:
- gecko: b2g-inbound:c5d205aa662c
- gaia: master:40407f07fe3700af2145ff032cfef21171a75327
Summary: [B2G][Open_C][Camera]Graphical issue appears after recording a video and switching back to camera mode → [Camera][Open_C] Viewfinder corruption appears after recording a video and switching back to camera mode
I don't see anything obvious in the logcat, and this doesn't affect other devices. Someone from our partner should take a look.
Whiteboard: [povb]
Component: Gaia::Camera → Vendcom
Keywords: qawanted
Whiteboard: [povb] → [POVB]
Qualcomm engineer reply to the problem:

The issue is because of recording hint being set to TRUE in camera preview mode. So, video stream is also getting initialized in camera preview.
 Ideally, when we switch to camera preview mode, recording hint has to be set to FALSE before starting preview. In android, application layer takes responsibility of setting/clearing Recording hint instead of HAL.
 Ofcourse, we can clear recording hint in HAL as well (in stopRecording) as in your comments. Just calling mParameters.updateRecordingHintValue(false); after stopping video channel should suffice. 

Meanwhile, I would recommend clearing recording hint from Application layer instead of doing it in HAL. If we do it in HAL, between successive recording sessions, preview channel will be closed and created again, which is unnecessary. Best place to do this is in application layer, after switching to camera preview mode, but before starting preview. Can you raise a Bugzilla about our concern?
Same issue as linked, already resolved in patch awaiting landing as per the recommendations as we clear it after stopping the video channel.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1007832
You need to log in before you can comment on or make changes to this bug.