Status

()

Core
Internationalization
P2
major
VERIFIED WONTFIX
17 years ago
15 years ago

People

(Reporter: Skewer, Assigned: Darin Fisher)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Whenever I load bug 59108, it will "double load" - before the page finishes
loading, it will stop and start over. This used to happen to me in Netscape 4,
and it might even be the same problem that caused the double loading before.
This happens on other pages, but seems to be 100% reproducible with that URL.

Build: 2001091608 W98

Comment 1

17 years ago
This is a dup... pretty sure it's bug 88701, but check the screenshot there to
make sure it's what you're seeing.

*** This bug has been marked as a duplicate of 88701 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
No, it's not doubling the form, it's loading the page twice.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 3

17 years ago
I see what you mean (0.9.4/Linux); sorry for the hasty dup.

I'm not sure this is a network bug, though -- the whole page loading apparatus
looks like it's starting over.  I wonder if there's anything weird in the source
of that page.

OS: Windows 98 → All
(Reporter)

Comment 4

17 years ago
I'm seeing a much more serious problem. When I edit the bug that comes before
bug 59108 on the list, the returned page stops, then I get a message asking me
if I want to resend the POSTDATA. If things like this happen on credit card
transaction pages or other such important things, we could have VERY serious
problems. Try it -- get a bug list and edit the bug that falls before bug 59108!
Severity: normal → critical
Status: REOPENED → NEW
Keywords: mozilla0.9.6, nsbeta1, nsCatFood, nsdogfood
Summary: Bug page loads twice → Some pages load twice

Comment 5

17 years ago
darin
Assignee: neeti → darin
(Assignee)

Comment 6

17 years ago
skewer: what version of mozilla were you using when you first/last noticed this
problem?
(Reporter)

Comment 7

17 years ago
Darin: You can see from my comments, this was reported with 2001091608 W98. This
still happens in today's build. 100% reproducible after shift+reload.
(Assignee)

Comment 8

17 years ago
this is key: "100% reproducible after shift+reload"

skewer: can you reproduce it without shift+reload?
(Reporter)

Comment 9

17 years ago
No, because normal reload does not download the page; it only checks for updates
and displays the cached page, which would not exhibit this bug (leading to
suspicion that this is a networking problem). This also happens the first time
you load the page since it has expired from the cache.

Updated

17 years ago
Blocks: 104166
(Reporter)

Updated

17 years ago
Keywords: nsbeta1
(Assignee)

Comment 10

17 years ago
yeah.. i'm seeing this too.. starting with an empty disk cache shows the problem
every time.

-> 0.9.6
Severity: critical → major
Status: NEW → ASSIGNED
Priority: -- → P2
Target Milestone: --- → mozilla0.9.6
(Assignee)

Comment 11

17 years ago
just tried this with the 2001103113 linux build, and i can't repro this anymore.

marking WORKSFORME.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 12

16 years ago
skewer: if this doesn't happen to you anymore, can you mark as VERIFIED?
Keywords: verifyme
(Reporter)

Comment 13

16 years ago
It appears that bug 59108 is still loading twice, but only the scrollbar in the
listbox is being drawn (instead of the whole page) in the first load. Since this
*virtually* solves the problem, I'll verify. There may still be a performance
issue but when AMD releases their ClawHammer CPU's it won't matter anyway.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 14

16 years ago
On second thought, the problem may not be visible anymore, but I can still see
Mozilla clearly loading the page twice in my proxy log. This bug may be less
visible but it still happens. Reopening.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 15

16 years ago
Created attachment 99058 [details]
http log demonstrating the double load

yup, i'm able to repro this too (linux trunk build 2002091108).  from the log
it appears that someone above necko is canceling the first load... not sure
why, but i'm looking to see.

Updated

16 years ago
Keywords: mozilla0.9.6 → mozilla1.2
Try deleting this line form your prefs.js file:
user_pref("intl.charset.detector", "zh_parallel_state_machine");
another to solve this bug is by selecting the menu:
View->Character Coding->Auto-Detect->(Off)
Target Milestone: mozilla0.9.6 → ---

Comment 18

16 years ago
-verifyme & mozilla1.2
Is this a config problem or a bug in Autodetect?
Should this be moved to HTTP or some other component?
Do we need to get this assigned->fixed for the Mozilla 1.3a?
Keywords: mozilla1.2, verifyme
(Assignee)

Comment 19

16 years ago
cc'ing nhotta and shanjian... looks like a problem related to charset
auto-detection.

Comment 20

16 years ago
bugzilla does not have charset meta tag, so when autodetector in on, new charset
will be detected if the page contains some special character. The character in
the link can be found in comment #68. So far, we do network reload if doc can be
found in cache for charset reload. It might also be possible the because charset
reload is issued before the first reload is ready, so there is no cache, and
network reload happens. If the concern is about how charset reload should
happen, we have other bugs and this behavior won't be changed soon. For Post
data concern, that has been addressed. Autodetection will be disabled for post
page. 

Comment 21

15 years ago
via mail: the previous comment referenced 
http://bugzilla.mozilla.org/show_bug.cgi?id=59108

Comment 22

15 years ago
change component to i18n. resolve it as wontfix.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago15 years ago
Component: Networking → Internationalization
Resolution: --- → WONTFIX

Updated

15 years ago
QA Contact: benc → ylong

Comment 23

15 years ago
Mark as verified as won't fix per comment #20.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.