Closed Bug 999914 Opened 6 years ago Closed 6 years ago

[RTSP] Enable RTSP video by default since v2.0

Categories

(Firefox OS Graveyard :: RTSP, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
2.0 S1 (9may)

People

(Reporter: ethan, Assigned: ethan)

Details

(Whiteboard: [p=1])

Attachments

(1 file, 1 obsolete file)

RTSP video shall be supported in v2.0.
Attached patch Enable RTSP video (obsolete) — Splinter Review
Enable RTSP video by the preference setting.
Assignee: nobody → ettseng
Whiteboard: [p=1]
Target Milestone: --- → 2.0 S1 (9may)
As I know, we decided to disable RTSP video by default in v1.3 and 1.4 because some basic functions didn't meet quality criteria then. Such as:
1. Seek function doesn't work well.
2. Crash occurs too often.
3. End-of-stream problem.

Most of these issues were already resolved in mozilla-central.
I think it's time to turn on RTSP video by default so that QA engineers can help to do more comprehensive tests.
In the meanwhile, we are toiling to build automated tests for RTSP in order to ensure its quality.

Vincent and Ken, how do you think?
Let's turn in on?
Flags: needinfo?(vchang)
Flags: needinfo?(kchang)
Sure, let's turn on RTSP by default in mozilla-central.
Flags: needinfo?(kchang)
Comment on attachment 8410750 [details] [diff] [review]
Enable RTSP video

Steve,
We are going to turn on RTSP video again. :)
Attachment #8410750 - Flags: review?(sworkman)
Flags: needinfo?(vchang)
Update commit message.
Attachment #8410750 - Attachment is obsolete: true
Attachment #8410750 - Flags: review?(sworkman)
Attachment #8410850 - Flags: review?(sworkman)
Comment on attachment 8410850 [details] [diff] [review]
Enable RTSP video

Review of attachment 8410850 [details] [diff] [review]:
-----------------------------------------------------------------

Awesome! Great work getting this over the finish line!
Attachment #8410850 - Flags: review?(sworkman) → review+
(In reply to Steve Workman [:sworkman] from comment #6)
> Awesome! Great work getting this over the finish line!
Steve,
We couldn't accomplish this without your help. Thanks!!
https://hg.mozilla.org/mozilla-central/rev/91946180b1e7
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Hi ettseng 

Could kindly help to specify which patches should i need to pick up if i want to enable rtsp video on v1.4?
Flags: needinfo?(ettseng)
This one: attachment 8410850 [details] [diff] [review]
Flags: needinfo?(ettseng)
(In reply to Ethan Tseng [:ethan] from comment #12)
> This one: attachment 8410850 [details] [diff] [review]

I means if there are some other patches needed.
attachment 8410850 [details] [diff] [review] just enable the rtsp video.

In another word,do all issues of rtsp video mentioned in comment2 are handled on v1.4?
Flags: needinfo?(ettseng)
(In reply to Ming from comment #13)
> I means if there are some other patches needed.
> attachment 8410850 [details] [diff] [review] just enable the rtsp video.
> In another word,do all issues of rtsp video mentioned in comment2 are
> handled on v1.4?

No. Since RTSP video is not enabled and not announced as a feature in v1.4, we don't fix most of the issues on this version.

The meta bug of the seek issue is bug 898866.
The seek problem was fixed in several bugs that blocks this bug: bug 947101, bug 947113 and bug 961926.

The end-of-stream problem was fixed by bug 951278. It caused a regression and was fixed in bug 1015169.
It also cause another potential problem and was fixed in bug 1021006.
(Please refer to https://bugzilla.mozilla.org/show_bug.cgi?id=951278#c40)

However, there are so many other major changes in v2.0 and made the dependency complicated.
I don't think it's feasible to simply apply those patches.
May I know why do you try to enable RTSP video in v1.4?
Flags: needinfo?(ettseng)
(In reply to Ethan Tseng [:ethan] from comment #14)

> May I know why do you try to enable RTSP video in v1.4?

Thanks very much . 
We'll estimate whether if it worth us to enable Rtsp video,which depends on the work's load and complexity.
You need to log in before you can comment on or make changes to this bug.