Closed Bug 999926 Opened 8 years ago Closed 8 years ago

unused-gc-things can get pretty big and never seems to be collected/released

Categories

(Core :: JavaScript: GC, defect)

30 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 989379

People

(Reporter: kael, Unassigned)

Details

I've got a handful of tabs open that are pretty light on content. It seems like over time while I navigated around in them, they accumulated unused-gc-things. GC/CC/Minimize memory usage don't seem to release them. (I'm not entirely sure what this category represents).


│    ├──102.96 MB (07.47%) -- top(http://www.mangahere.com/manga/xxx/v05/c018/18.html, id=133)
│    │  ├───69.08 MB (05.01%) -- js-zone(0x2168f800)
│    │  │   ├──53.49 MB (03.88%) ── unused-gc-things
│    │  │   ├──14.24 MB (01.03%) ++ strings
│    │  │   └───1.35 MB (00.10%) ++ (6 tiny)
│    │  └───33.88 MB (02.46%) ++ active
│    ├──100.38 MB (07.29%) -- top(http://www.mangahere.com/manga/yyy/c005/2.html, id=135)
│    │  ├───66.30 MB (04.81%) -- js-zone(0x21771c00)
│    │  │   ├──50.73 MB (03.68%) ── unused-gc-things
│    │  │   ├──14.24 MB (01.03%) ++ strings
│    │  │   └───1.33 MB (00.10%) ++ (6 tiny)
│    │  └───34.08 MB (02.47%) ++ active
│    ├───97.75 MB (07.10%) -- top(http://www.mangahere.com/manga/zzz/v01/c001/6.html, id=137)
│    │   ├──63.61 MB (04.62%) -- js-zone(0x21775000)
│    │   │  ├──47.92 MB (03.48%) ── unused-gc-things
│    │   │  ├──14.23 MB (01.03%) ++ strings
│    │   │  └───1.46 MB (00.11%) ++ (6 tiny)
│    │   └──34.14 MB (02.48%) ++ active

I think 50mb of unused-gc-things total would make sense, but per-tab is a bit unreasonable. Every one of these tabs that I've actively browsed through has this much. (It's possible this page's JS has some sort of leak, but that would surprise me given that it's a simple image browsing site with some trivial event handlers.)

Overall stats:
507.52 MB (100.0%) -- js-main-runtime-gc-heap-committed
├──297.26 MB (58.57%) -- unused
│  ├──297.26 MB (58.57%) ── gc-things
│  └────0.00 MB (00.00%) ++ (2 tiny)
└──210.27 MB (41.43%) -- used
   ├──197.74 MB (38.96%) ── gc-things
   ├────9.34 MB (01.84%) ── chunk-admin
   └────3.18 MB (00.63%) ── arena-admin

This is mostly relevant given
1,777.24 MB ── private
1,890.65 MB ── resident
2,852.92 MB ── vsize

Probably time to restart this firefox.exe. Wish I didn't have to do that so often.
I'll just dup this to bug 989379, which is about this very same topic.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 989379
You need to log in before you can comment on or make changes to this bug.