Closed Bug 999970 Opened 8 years ago Closed 4 years ago

abv.bg sends desktop site to Firefox OS

Categories

(Web Compatibility :: Mobile, defect, P5)

All
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: hsteen, Unassigned)

References

()

Details

(Whiteboard: [country-bg][serversniff][contactready])

Attachments

(1 file)

This site is not configured to detect Firefox OS devices as smartphones, it sends desktop content. Below is some analysis of the HTTP traffic to show how the browser detection works:

Firefox Android redirected to http://m.abv.bg, Firefox OS not redirected

Selected HTTP response headers:

Response for: 'Mozilla/5.0 (Mobile; rv:18.1) Gecko/18.1 Firefox/18.1'
Response Status: 200
content-length: 0
content-type: text/html;charset=UTF-8

Response for: 'Mozilla/5.0 (Android; Mobile; rv:26.0) Gecko/26.0 Firefox/26.0'
Response Status: 302
content-length: 0
location: http://m.abv.bg
Duplicate of this bug: 999971
Priority: -- → P5
Closing as we are not working on Firefox OS anymore.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.