Bug 285718 (Persian)

[META] Tracker for Persian support in Mozilla applications

ASSIGNED
Assigned to

Status

()

Core
Internationalization
ASSIGNED
12 years ago
11 months ago

People

(Reporter: zwnj, Assigned: zwnj)

Tracking

(Depends on: 27 bugs, {meta})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 obsolete attachments)

(Assignee)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Tracking bug for Persian

Reproducible: Always

Steps to Reproduce:

Comment 1

12 years ago
i don't think two separate tracking bugs are needed for this?

*** This bug has been marked as a duplicate of 108492 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

12 years ago
Roozbeh has not updated/managed his bug tracker for long time.  I wanna to close
that one and open a new one.  Because of new mozilla's buzilla policy, I cannot
do everything in that one.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Assignee)

Comment 3

12 years ago
Would someone assign this bug to me, please?

Updated

12 years ago
Assignee: chofmann → behnam

Comment 4

12 years ago
*** Bug 108492 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

12 years ago
Status: UNCONFIRMED → ASSIGNED
Depends on: 268113, 274152, 284927
Ever confirmed: true
QA Contact: chofmann → behnam
(Assignee)

Updated

12 years ago
Summary: Meta Bug: Behnam's tracking bug for Persian → Meta Bug: Tracking bug for Persian
(Assignee)

Updated

12 years ago
Depends on: 69230
(Assignee)

Updated

12 years ago
Depends on: 204767

Updated

12 years ago
Keywords: meta
(Assignee)

Updated

12 years ago
Depends on: 199519
(Assignee)

Updated

12 years ago
Depends on: 96057, 137995, 154625, 207186
(Assignee)

Updated

12 years ago
Depends on: 204272, 260663
(Assignee)

Updated

12 years ago
Depends on: 296605
(Assignee)

Updated

12 years ago
Depends on: 296689
(Assignee)

Updated

12 years ago
Depends on: 218823, 224685
(Assignee)

Updated

12 years ago
Depends on: 298004
(Assignee)

Comment 5

12 years ago
Depends on Bug 231701 - format=flowed DelSp=yes not supported (RFC 3676)

Because:  Lake of line-break/paragraph-separator detection cause many BiDi
problems, i.e. mail client fails to auto-align paragraph.
Depends on: 231701
(Assignee)

Updated

12 years ago
No longer depends on: 231701
(Assignee)

Updated

12 years ago
Depends on: 231701
(Assignee)

Comment 6

12 years ago
Bug 290351 - Registration of Persian (fa-IR) Firefox localization
Depends on: 290351
(Assignee)

Updated

12 years ago
Alias: Persian
(Assignee)

Comment 7

12 years ago
Bug 177508 - Internationalization - ALT-key / underlined keyboard shortcuts |
mnemonics | access keys do not work in all input locales
Depends on: 177508
(Assignee)

Comment 8

12 years ago
Bug 301896 -- Layout: BiDi Hebrew & Arabic -- Tab selection with Alt+NUM is
reversed in BiDi layouts
Depends on: 301896
(Assignee)

Comment 9

12 years ago
Bug 301897 -- Internationalization -- Alt+NUM (tab jumping) cannot be localized
Depends on: 301897
(Assignee)

Updated

12 years ago
Depends on: 304523
(Assignee)

Comment 10

12 years ago
Bug 304523 -- inline html tags break arabic joining
(Assignee)

Comment 11

12 years ago
Bug 69230 -- Accelerators should not be affected by keyboard group/level

Updated

12 years ago
Depends on: 305602
(Assignee)

Comment 12

12 years ago
Bug 305602 -- Bidi: Difficult to select to end of line using the mouse when line
ends with reverse-direction text
(Assignee)

Comment 13

12 years ago
Bug 236135 -- word-internal tags force word-final shaping in Arabic
Depends on: 236135
(Assignee)

Comment 14

11 years ago
Bug 162081
Wrong letter is underlined as accesskey / mnemonic when widget direction is RTL
Depends on: 162081
(Assignee)

Comment 15

11 years ago
Bug 280936 -- In right-to-left languages, char zwnj (U+200C) is not handled
Depends on: 280936
(Assignee)

Comment 16

11 years ago
From MetaNet:
Bug #121633 - [bidi]reflowinlineframes accumulates margins on the right side.
Bug #237370 - unexpected behavior of borders in RTL text
Bug #258928 - misplaced padding of inlines which are RTLed or have RTL text
Bug #258949 - padding not applied or incorrectly applied to :after pseudoelement
Bug #98157 - Caret does not have bidi marker in certain dialog boxes
Bug #174470 - [BC] Bidi : Border-collapse property in RTL direction is not working correctly
Bug #206089 - Tiny layout problem in Arabic or Hebrew (Right to Left) language
Bug #121633 - [bidi]reflowinlineframes accumulates margins on the right side.
Bug #6976 - Horizontal scrollbar is missing. {was: "create scrollbar for / allow scrolling to overflow top (above) / left of container (Left side of the page is cut)"}
Bug #99823 - Layout of Arabic (shaped) text is faulty
(Assignee)

Updated

11 years ago
Depends on: 174470
(Assignee)

Comment 17

11 years ago
Created attachment 231879 [details]
Firefox 2.0b1 nightly with 'fa' langpack installed.  Screenshot 01

Good: (green)
- Bidi icons in toolbar.
- Bidi marked XUL. (translation)
- 

Bad: (red)
- Font problems. (without pango)
(Assignee)

Comment 18

11 years ago
Created attachment 231880 [details]
Firefox 2.0b1 nightly with 'fa' langpack installed.  Screenshot 02

Bad: (red)
- No file name, address, etc detection makes status-bar buggy with texts and addresses.
(Assignee)

Comment 19

11 years ago
Created attachment 232152 [details]
Firefox 2.0b1 nightly with 'fa' langpack installed.  Screenshot 03

No more good (grean) things. :(

Bad: (red)
- Bad font selection (pango) for parenthesis of shortcuts.
- ZWNJ have been removed in XUL texts. (Bug 280936)
- GTK2-based doesn't work well with RTL XUL. (I think we don't have such problems in Win32 backend)
- And the well-known status bar problem with RTL languages. (Filed bug?)
(Assignee)

Comment 20

11 years ago
Created attachment 232154 [details]
Firefox 2.0b1 nightly with 'fa' langpack installed.  Screenshot 04

Good: (green)
- Arabic HARKATs are placed well with pango enabled.

Not sure: (gray)
- ZWNJ problems in translations. (see also Bug 280936)  I'm not what the bug is yet!  The first appearance of "بارگیری‌ها" doesn't have ZWNJ displayed, and the second one does!  I'm going to take a look deep on it.

Bad: (red)
- Underline breaks Arabic joining.  Note that we didn't have this problem with Fx1.0.  As you can see, there's no problem in XUL menus too.  Now it's a new problem!
(Assignee)

Updated

11 years ago
Depends on: 347502
(Assignee)

Updated

11 years ago
Depends on: 347504
(Assignee)

Updated

11 years ago
Depends on: 347505
(Assignee)

Updated

11 years ago
Depends on: 265030
(Assignee)

Updated

11 years ago
Depends on: 347510
(Assignee)

Updated

11 years ago
Depends on: 347514
(Assignee)

Updated

11 years ago
Depends on: 347515
(Assignee)

Updated

11 years ago
Depends on: 347621
(Assignee)

Updated

11 years ago
Depends on: 347632
(Assignee)

Updated

11 years ago
Depends on: 347634
(Assignee)

Updated

11 years ago
Depends on: 297790
(Assignee)

Updated

11 years ago
Depends on: 151374
(Assignee)

Updated

11 years ago
Depends on: 330863
(Assignee)

Updated

11 years ago
Depends on: 192767
(Assignee)

Updated

11 years ago
Depends on: 265276
(Assignee)

Updated

11 years ago
Depends on: 252039
(Assignee)

Updated

11 years ago
Depends on: 347977
(Assignee)

Updated

11 years ago
Depends on: 347981
(Assignee)

Updated

11 years ago
Depends on: 348221
(Assignee)

Updated

11 years ago
Depends on: 348233
(Assignee)

Updated

11 years ago
Depends on: 348712
(Assignee)

Updated

11 years ago
Depends on: 348724
(Assignee)

Updated

11 years ago
Depends on: 348728
(Assignee)

Updated

11 years ago
Depends on: 349154
(Assignee)

Updated

11 years ago
Depends on: 349176
(Assignee)

Updated

11 years ago
Depends on: 349180
(Assignee)

Updated

11 years ago
Depends on: 349193
(Assignee)

Updated

11 years ago
Depends on: 349207
(Assignee)

Updated

11 years ago
No longer depends on: 349207
Summary: Meta Bug: Tracking bug for Persian → [META] Tracking bug for Persian
(Assignee)

Updated

11 years ago
Depends on: 349207
(Assignee)

Updated

11 years ago
Depends on: 349904
(Assignee)

Updated

11 years ago
Depends on: 350029
(Assignee)

Updated

11 years ago
Depends on: 350594
(Assignee)

Updated

11 years ago
Depends on: 350595
(Assignee)

Updated

11 years ago
Depends on: 350596
(Assignee)

Updated

11 years ago
Depends on: 350597
(Assignee)

Updated

11 years ago
Depends on: 350605
(Assignee)

Updated

11 years ago
Depends on: 350611
(Assignee)

Updated

11 years ago
Depends on: 350764
(Assignee)

Updated

11 years ago
Attachment #231879 - Attachment is obsolete: true
(Assignee)

Updated

11 years ago
Attachment #231880 - Attachment is obsolete: true
(Assignee)

Updated

11 years ago
Attachment #232152 - Attachment is obsolete: true
(Assignee)

Updated

11 years ago
Attachment #232154 - Attachment is obsolete: true
(Assignee)

Updated

11 years ago
No longer depends on: 347621
(Assignee)

Updated

11 years ago
Depends on: 351562
(Assignee)

Updated

11 years ago
Depends on: 154632
(Assignee)

Updated

11 years ago
Depends on: 265070
(Assignee)

Updated

11 years ago
Depends on: 353682
(Assignee)

Updated

11 years ago
Depends on: 354962
(Assignee)

Updated

10 years ago
Depends on: 397632
(Assignee)

Updated

10 years ago
Depends on: 390140
(Assignee)

Updated

10 years ago
Depends on: 390138
(Assignee)

Updated

10 years ago
Depends on: 390137
(Assignee)

Updated

10 years ago
Depends on: 390141
(Assignee)

Updated

10 years ago
Depends on: 397900
(Assignee)

Updated

10 years ago
Depends on: 397905
Depends on: 398998, 398999, 399000, 399001, 399003
No longer depends on: 398998, 398999, 399000, 399001, 399003
Duplicate of this bug: 314969
Duplicate of this bug: 289290
(Assignee)

Updated

10 years ago
Depends on: 399899
(Assignee)

Updated

10 years ago
Depends on: 397803
(Assignee)

Updated

10 years ago
Depends on: 399217
Depends on: 404149
(Assignee)

Updated

10 years ago
Depends on: 312436
(Assignee)

Updated

10 years ago
Depends on: 406314
(Assignee)

Updated

10 years ago
Depends on: 402247
(Assignee)

Updated

10 years ago
Depends on: 412273
(Assignee)

Updated

10 years ago
Depends on: 412415
QA Contact: bugs+behnam → persian.fa
(Assignee)

Updated

9 years ago
Depends on: 417489
(Assignee)

Updated

9 years ago
Depends on: 417765
(Assignee)

Updated

9 years ago
Depends on: 417899
(Assignee)

Updated

9 years ago
Depends on: 402607
Depends on: 415597
(Assignee)

Updated

9 years ago
Depends on: 428492
(Assignee)

Updated

9 years ago
Depends on: 234856
(Assignee)

Updated

9 years ago
Depends on: 427957
(Assignee)

Updated

9 years ago
Depends on: 435856
(Assignee)

Updated

9 years ago
Summary: [META] Tracking bug for Persian → [META] Tracker for Persian suuport in Mozilla applications
(Assignee)

Updated

9 years ago
Depends on: 390028

Updated

9 years ago
Summary: [META] Tracker for Persian suuport in Mozilla applications → [META] Tracker for Persian support in Mozilla applications
Depends on: 353087
No longer depends on: 347510
(Assignee)

Updated

8 years ago
Depends on: 484117
Adding the dependencies removed from bug 415597 to this bug for tracking purposes.
Depends on: 312891
No longer depends on: 349154
(Assignee)

Updated

4 years ago
Depends on: 800188

Updated

2 years ago
Depends on: 1232445
No longer depends on: 1232445
Component: Tracking → Internationalization
QA Contact: chofmann
You need to log in before you can comment on or make changes to this bug.