Bug 333492 (newatk)

Implement new-atk

RESOLVED FIXED in mozilla1.9alpha1

Status

()

defect
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: aaronlev, Assigned: aaronlev)

Tracking

({access, meta})

Firefox Tracking Flags

(Not tracked)

Details

Assignee

Description

13 years ago
We need to implement the reorganization of document structure and text as explained here:
http://www.mozilla.org/access/unix/new-atk.html

We will use the last column in the table as agreed by the FSG - "ATK
using Hypertext and Hyperlink children"

We will move more of the code into cross-platform areas (mozilla/accessible/src/base) to make implementation of ATK-like interfaces easier on other platforms.
No longer depends on: fox2access
Assignee

Updated

13 years ago
Target Milestone: --- → mozilla1.9alpha
Assignee

Updated

13 years ago
No longer blocks: fox2access
Depends on: fox2access
Assignee

Updated

13 years ago
Alias: newatk
Assignee

Comment 1

13 years ago
The following document may also provide useful info:
http://accessibility.freestandards.org/a11yspecs/atspi/adoc/ADOC_ATSPI.htm
Assignee

Updated

13 years ago
Blocks: 324745
Assignee

Updated

13 years ago
Depends on: 334650

Updated

13 years ago
Depends on: 339310

Updated

13 years ago
Depends on: 339311

Updated

13 years ago
Depends on: 339314
Assignee

Updated

13 years ago
Depends on: 340661
Assignee

Updated

13 years ago
Blocks: 334650, 339310, 340661
No longer depends on: 334650, 339310, 339311, 339314, 340661
Assignee

Updated

13 years ago
Depends on: 340665
Assignee

Updated

13 years ago
Depends on: 340667
Assignee

Updated

13 years ago
Depends on: 340668
Assignee

Updated

13 years ago
Depends on: 340670
Assignee

Updated

13 years ago
Depends on: 340671
Assignee

Updated

13 years ago
Depends on: 340672

Updated

13 years ago
No longer blocks: 339310
Depends on: 340777
Assignee

Updated

13 years ago
Depends on: 340802
Assignee

Updated

13 years ago
Depends on: textattra11y
Assignee

Updated

13 years ago
Depends on: 340822
Assignee

Updated

13 years ago
Depends on: 340825
Assignee

Updated

13 years ago
Depends on: 340827
Assignee

Updated

13 years ago
Depends on: 340829
Assignee

Updated

13 years ago
Depends on: 340830
Assignee

Updated

13 years ago
No longer blocks: 340661
Depends on: 340661
Assignee

Updated

13 years ago
Depends on: 340833

Comment 2

13 years ago
That second document is incomplete and not entirely up to date.
Assignee

Updated

13 years ago
Depends on: 341013
Assignee

Updated

13 years ago
Depends on: 341386
Assignee

Updated

13 years ago
Depends on: 341747
Assignee

Updated

13 years ago
Depends on: 342045
Assignee

Updated

13 years ago
Depends on: 342288
Assignee

Updated

13 years ago
Depends on: 342308
Assignee

Updated

13 years ago
Depends on: 312093
Assignee

Updated

13 years ago
No longer depends on: 340777
Assignee

Updated

13 years ago
No longer depends on: 340670
Assignee

Updated

13 years ago
No longer depends on: 342288
Assignee

Updated

13 years ago
No longer depends on: 342308
Assignee

Updated

13 years ago
No longer depends on: 340830
Assignee

Updated

13 years ago
Depends on: 342596
Assignee

Updated

13 years ago
Depends on: 322903
Assignee

Updated

13 years ago
No longer depends on: 342596
Assignee

Updated

13 years ago
Depends on: 285167
Assignee

Updated

13 years ago
Blocks: keya11y
Assignee

Updated

13 years ago
No longer depends on: fox2access
Assignee

Updated

13 years ago
No longer depends on: 285167
Assignee

Updated

13 years ago
Depends on: 255073
Assignee

Comment 3

13 years ago
*** Bug 337530 has been marked as a duplicate of this bug. ***
Assignee

Updated

13 years ago
Depends on: 337533
Assignee

Updated

13 years ago
Depends on: 313443
Assignee

Updated

13 years ago
Depends on: 278034
Assignee

Updated

13 years ago
Depends on: 275010
Assignee

Updated

13 years ago
Depends on: 343136
Assignee

Updated

13 years ago
Depends on: 343150
Assignee

Updated

13 years ago
Depends on: 343156
Assignee

Comment 4

13 years ago
*** Bug 309282 has been marked as a duplicate of this bug. ***
Assignee

Updated

13 years ago
Depends on: 334353
Assignee

Updated

13 years ago
Depends on: 260921
Assignee

Updated

13 years ago
Depends on: 214580
Assignee

Comment 5

13 years ago
*** Bug 187212 has been marked as a duplicate of this bug. ***
Assignee

Updated

13 years ago
Depends on: 320357
Assignee

Updated

13 years ago
Depends on: 322453
Assignee

Updated

13 years ago
No longer depends on: 214580
Assignee

Updated

13 years ago
Depends on: 344392

Updated

13 years ago
Depends on: 344901
Assignee

Updated

13 years ago
Depends on: 345143
Assignee

Updated

13 years ago
No longer depends on: 345143
Assignee

Updated

13 years ago
Depends on: 345192
Depends on: 345275

Updated

13 years ago
Depends on: 345421

Updated

13 years ago
Depends on: 345422

Updated

13 years ago
Depends on: 345424

Updated

13 years ago
Depends on: 345434
Assignee

Updated

13 years ago
Depends on: 345723
Assignee

Updated

13 years ago
Keywords: meta

Updated

13 years ago
Depends on: 345825
Depends on: 346621
Assignee

Updated

13 years ago
Depends on: 346833
Assignee

Updated

13 years ago
Depends on: 346846
Assignee

Updated

13 years ago
Depends on: 346906
Assignee

Updated

13 years ago
No longer depends on: 346833
Assignee

Updated

13 years ago
No longer depends on: 345723
Assignee

Updated

13 years ago
Depends on: 347171

Updated

13 years ago
No longer depends on: 322453
Assignee

Updated

13 years ago
Depends on: 348037
Assignee

Updated

13 years ago
Depends on: 348616
Assignee

Updated

13 years ago
Depends on: 348901
Assignee

Updated

13 years ago
Depends on: 349519
Assignee

Updated

13 years ago
Depends on: 349533

Updated

13 years ago
Depends on: 349635
Assignee

Updated

13 years ago
Depends on: 349909
Assignee

Updated

13 years ago
No longer depends on: 278034
Assignee

Updated

13 years ago
No longer depends on: 342045
Assignee

Updated

13 years ago
Depends on: 350063
Assignee

Updated

13 years ago
Depends on: 350565
Assignee

Updated

13 years ago
Depends on: 352150
Assignee

Updated

13 years ago
Depends on: 352194
Assignee

Updated

13 years ago
Depends on: 352195
Assignee

Updated

13 years ago
Depends on: 352214
Assignee

Updated

13 years ago
Depends on: 352340
Assignee

Updated

13 years ago
Depends on: 352205
Assignee

Updated

13 years ago
Depends on: 352522

Updated

13 years ago
Depends on: 352533
Assignee

Updated

13 years ago
No longer depends on: 352205
Assignee

Updated

13 years ago
No longer depends on: 352533

Updated

13 years ago
Depends on: 353187

Updated

13 years ago
Blocks: 353197
Assignee

Updated

13 years ago
Depends on: 353293
Assignee

Updated

13 years ago
No longer blocks: 353197
Depends on: 353197
Assignee

Updated

13 years ago
Depends on: 353200
Assignee

Updated

13 years ago
Depends on: 350381
Assignee

Updated

13 years ago
Depends on: 343904
Assignee

Updated

13 years ago
Depends on: 352520
Assignee

Updated

13 years ago
Depends on: 354832
Assignee

Updated

13 years ago
Depends on: 357056
Assignee

Updated

13 years ago
Depends on: 357032
Assignee

Updated

13 years ago
Depends on: 357430
Assignee

Updated

13 years ago
Depends on: 357432
Assignee

Updated

13 years ago
Depends on: 357837
Assignee

Updated

13 years ago
Depends on: 357625
Assignee

Updated

13 years ago
Depends on: 356152
Assignee

Updated

13 years ago
Depends on: 358085
Assignee

Updated

13 years ago
Depends on: 358979
Assignee

Updated

13 years ago
Depends on: 359204
Assignee

Updated

13 years ago
Depends on: 359210
Assignee

Updated

13 years ago
No longer depends on: 359204

Updated

13 years ago
Depends on: 359790

Updated

13 years ago
Depends on: 359792
Assignee

Updated

13 years ago
Depends on: 360003
Assignee

Updated

13 years ago
Depends on: 360184

Updated

13 years ago
Depends on: 356347

Updated

13 years ago
Depends on: 356045
Assignee

Updated

13 years ago
Depends on: 357230
Assignee

Updated

13 years ago
Depends on: 359924
Assignee

Updated

13 years ago
Depends on: 358782
Assignee

Updated

13 years ago
Depends on: 360865
Assignee

Updated

13 years ago
Depends on: 355380
Depends on: 362445
Assignee

Updated

13 years ago
Depends on: 363200
Assignee

Updated

13 years ago
Depends on: 363198
Assignee

Updated

13 years ago
Depends on: 363214

Updated

13 years ago
Depends on: 363646
No longer depends on: 358782
Assignee

Updated

13 years ago
Depends on: 365685

Updated

13 years ago
Depends on: 366443
Assignee

Updated

13 years ago
No longer depends on: 359792
Depends on: 366527
Depends on: 366000
Assignee

Updated

13 years ago
Depends on: 365683
Assignee

Updated

13 years ago
Depends on: 367337
Assignee

Updated

13 years ago
Depends on: statesa11y
Assignee

Updated

13 years ago
Depends on: 367653
Assignee

Updated

13 years ago
No longer depends on: 357430
Assignee

Updated

13 years ago
No longer depends on: textattra11y
Assignee

Updated

13 years ago
No longer depends on: 348901
Assignee

Updated

13 years ago
No longer depends on: 360003
Assignee

Updated

13 years ago
No longer depends on: 360184
Assignee

Updated

13 years ago
No longer depends on: 357432
Assignee

Updated

13 years ago
No longer depends on: 343904
Assignee

Updated

13 years ago
No longer depends on: 366527
Assignee

Comment 6

13 years ago
Big bug reorg. Closing this as basically being basically feature complete, and moving remaining bugs to other meta bugs.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Assignee

Updated

13 years ago
No longer depends on: 366000

Updated

12 years ago
No longer depends on: 363214
You need to log in before you can comment on or make changes to this bug.