Closed Bug 1101113 (system-dialog-rtl) Opened 5 years ago Closed 5 years ago

[RTL] System Dialogs

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

defect
Not set

Tracking

(feature-b2g:2.2+, b2g-v2.2 affected)

RESOLVED FIXED
2.2 S2 (19dec)
feature-b2g 2.2+
Tracking Status
b2g-v2.2 --- affected

People

(Reporter: swilkes, Assigned: gmarty)

References

Details

(Whiteboard: [rtl-meta][systemsfe])

Attachments

(1 file)

46 bytes, text/x-github-pull-request
etienne
: review+
Details | Review
This is the meta bug for Arabic language support in Sys FE System Dialogs. The release target for full Gaia (all apps) Arabic support is 2.2. 

Per usual, strings for translation will be filed in the L10N component and noted as blocking this bug.

The bidi UX pattern (OS wide) is here:
https://mozilla.app.box.com/s/0y1amh4rwpp6brcxd1hk
Blocks: system-rtl
No longer blocks: gaia-rtl
feature-b2g: --- → 2.2+
Whiteboard: [systemsfe]
Assignee: nobody → gmarty
Attached file Github PR
This patch fixes RTL for system dialogs.
Etienne, can you have a look?
Attachment #8531705 - Flags: review?(etienne)
Comment on attachment 8531705 [details] [review]
Github PR

Looking good, I think we should attach some screenshots and have them UI-reviewed though.
(but maybe another process has already been agreed upon)
Attachment #8531705 - Flags: review?(etienne) → review+
Landed in master: https://github.com/mozilla-b2g/gaia/commit/1802d44011589ff7194252ec987ec159086cf42a
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Adding whiteboard tag [rtl-impact]
Whiteboard: [systemsfe] → [rtl-impact]
Whiteboard: [rtl-impact] → [rtl-meta]
Whiteboard: [rtl-meta] → [rtl-meta][systemsfe]
Keywords: verifyme
Hi Eric,
   This issue has been verified failed on Flame 2.2.
Reproduce rate:5/5
   We have file a new bug for this situation, see bug 1126209.Hope this can help you.Thanks.
QA Whiteboard: [MGSEI-Triage+]
Flags: needinfo?(echang)
See Also: → 1126209
Adding depends on 1126209
Depends on: 1126209
Flags: needinfo?(echang)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Peter, I don't think reopening this bug is the right action since it has a patch that landed 2 months ago. Which also kind of makes it not a meta bug. 

I'm going to re-resolve this one. Let's proceed with the new bug 1126209 and I'll move that bug's dependency to system-rtl instead of this one.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
No longer depends on: 1126209
No longer depends on: 1129520
See Also: → 1129520
Summary: [META] [RTL] System Dialogs → [RTL] System Dialogs
Target Milestone: --- → 2.2 S2 (19dec)
Clear "verifyme" in keywords.
Keywords: verifyme
Depends on: 1154209
Depends on: 1154647
You need to log in before you can comment on or make changes to this bug.