Closed Bug 242757 Opened 16 years ago Closed 15 years ago

New Extension API does not allow Files to be put into the chrome\icons\default folder

Categories

(Toolkit :: Add-ons Manager, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 289423
mozilla1.7.4

People

(Reporter: jedbro, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040313 Firefox/0.8.0+ (scragz)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040313 Firefox/0.8.0+ (scragz)

As discussed with Ben on the Extension Forum
http://forums.mozillazine.org/viewtopic.php?p=511847#511847

Pre 0.9 one was able to do the following in the install.js to add icons for
extension created windows.
var iconfolder = getFolder(getFolder("chrome", "icons"), "default");
  addFile(name, "quicknote-main.ico", iconfolder, "");
  addFile(name, "quicknote-main.xpm", iconfolder, ""); 

The new API currently doesn't allow this.

Reproducible: Always
Steps to Reproduce:
Flags: blocking0.9?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Not going to make the .9 train as it requires widget API changes, use the
workaround I described for now, will block 1.0. 
Flags: blocking1.0+
Flags: blocking0.9?
Flags: blocking0.9-
Priority: -- → P3
Target Milestone: --- → Firefox1.0beta
I'll talk to dan about this next week. This is widget related. 
Assignee: bugs → danm.moz
Not a "blocker"
Flags: blocking-aviary1.0+ → blocking-aviary1.0-
Assignee: danm.moz → nobody
Thanks to Benjamin, this is now implemented!

*** This bug has been marked as a duplicate of 289423 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.