Last Comment Bug 420815 - XUL Cache interferes with onload when loading multiple instances of the same XUL file
: XUL Cache interferes with onload when loading multiple instances of the same ...
Status: RESOLVED WORKSFORME
:
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: songbird
  Show dependency treegraph
 
Reported: 2008-03-03 19:40 PST by Matt Crocker
Modified: 2009-10-21 03:58 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Test XPI (5.14 KB, application/x-xpinstall)
2008-03-03 19:40 PST, Matt Crocker
no flags Details

Description Matt Crocker 2008-03-03 19:40:03 PST
Created attachment 307163 [details]
Test XPI

It is possible for XUL documents to miss the load event in the following scenario:
* Loading a chrome XUL file into multiple tabs at 
  the same time
* The URLs include a querystring
* The URLs are identical
* The XUL Cache is enabled
* The XUL file includes a JavaScript file

When loading the same XUL file in 5 tabs at once on average only 3 of the documents receive load events.  Changing any of the points above cause it to work just fine.

This is Firefox/3.0b3pre on a Mac Pro.

STR:
1. Install the attached test extension in Minefield
2. Restart
3. Wait 4 seconds
4. Note that the extension has opened multiple tabs
   containing the same XUL document
5. Note that only some of the tabs contain the 
   text "SEEN LOAD"
Comment 1 Wladimir Palant 2008-09-11 04:56:23 PDT
Bug 454772 is a similar issue though the scenario is somewhat different.
Comment 2 Wladimir Palant 2009-10-21 03:58:56 PDT
Works for me:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20091020 Minefield/3.7a1pre

This was probably fixed by bug 206691, just like bug 321099.

Note You need to log in before you can comment on or make changes to this bug.