Closed Bug 1133601 Opened 9 years ago Closed 9 years ago

Implement about:serviceWorker or something similar to show the active ServiceWorkers

Categories

(Core :: DOM: Workers, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla40
Tracking Status
firefox40 --- fixed

People

(Reporter: baku, Assigned: baku)

References

Details

Attachments

(1 file, 4 obsolete files)

      No description provided.
Attached patch gecko patch (obsolete) — Splinter Review
I wrote a small and quick demo about this and I add to change 2 lines in gecko. Here the patch. I don't think we should land this code, but it's useful to see what I wrote.
Attached file about-sw.xpi (obsolete) —
An horribly-written addon. It doesn't work with e10s yet.
When the addon is installed, the user can open about:sw and see the serviceWorkers used by the other tabs.
Attached patch gecko.patch (obsolete) — Splinter Review
Attachment #8565199 - Attachment is obsolete: true
Shane was also interested in Service Worker UI stuff in bug 1078808.
See Also: → 1078808
Shouldn't this be part of developer tools in some way? At least coordinated with them, I think.
(In reply to Anne (:annevk) from comment #6)
> Shouldn't this be part of developer tools in some way? At least coordinated
> with them, I think.

We plan on adding service workers to the storage inspector.
Assignee: nobody → mratcliffe
Ehsan, don't forget about this bug! Take a look at the addon. Then we can talk about a temporary solution waiting for something properly done by the devtools team.
Flags: needinfo?(ehsan)
(In reply to Michael Ratcliffe [:miker] [:mratcliffe] from comment #7)
> We plan on adding service workers to the storage inspector.

That only really makes sense for looking at the Cache objects. We still need some way to see which SWs are active, which network requests they have registered to modify, etc.
Ben Turner: +1
We need to have a way to see what the workers are doing and debug their code.
The add-on works great!  I talked to Andrea about this on IRC, and we're going to land a version of his add-on as a very basic level of developer support for now, until we have proper support for debugging and representing workers in devtools.
Flags: needinfo?(ehsan)
Attached patch about.patch (obsolete) — Splinter Review
This can be used as starting point.
Attachment #8565200 - Attachment is obsolete: true
Attachment #8565348 - Attachment is obsolete: true
Attachment #8589934 - Flags: review?(ehsan)
Assignee: mratcliffe → nobody
Assignee: nobody → amarchesini
Comment on attachment 8589934 [details] [diff] [review]
about.patch

Review of attachment 8589934 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/content/aboutServiceWorkers.xhtml
@@ +7,5 @@
> +<!DOCTYPE html [
> +<!ENTITY % htmlDTD PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "DTD/xhtml1-strict.dtd"> %htmlDTD;
> +<!ENTITY % globalDTD SYSTEM "chrome://global/locale/global.dtd"> %globalDTD;
> +<!ENTITY % brandDTD SYSTEM "chrome://branding/locale/brand.dtd"> %brandDTD;
> +<!ENTITY % networkingDTD SYSTEM "chrome://global/locale/aboutServiceWorkers.dtd"> %networkingDTD;

Please rename this to serviceworkersDTD.

::: toolkit/locales/en-US/chrome/global/aboutServiceWorkers.dtd
@@ +4,5 @@
> +
> +<!ENTITY aboutServiceWorkers.title                     "About ServiceWorkers">
> +<!ENTITY aboutServiceWorkers.maintitle                 "Registered ServiceWorkers">
> +<!ENTITY aboutServiceWorkers.warning_not_enabled       "ServiceWorkers are not enabled.">
> +<!ENTITY aboutServiceWorkers.warning_no_serviceworkers "No ServiceWorkers registered.">

Nit: "Service Workers".

Also, please add a LOCALIZATION NOTE saying that the term "Service Workers" should not be translated.  The note needs to go before each string that contains this phrase (all of them here, for example.)

::: toolkit/locales/en-US/chrome/global/aboutServiceWorkers.properties
@@ +3,5 @@
> +# file, You can obtain one at http://mozilla.org/MPL/2.0/.
> +
> +title = Origin: %S
> +
> +b2gtitle = B2G AppID %S - InBrowserElement %S

Nit: s/B2G/Firefox OS/.

Also please add the LOCALIZATION NOTEs for stuff that should not be translated here as well.

::: toolkit/locales/en-US/chrome/global/aboutSupport.dtd
@@ +54,5 @@
>  <!ENTITY aboutSupport.appBasicsEnabledPlugins "Enabled Plugins">
>  <!ENTITY aboutSupport.appBasicsBuildConfig "Build Configuration">
>  <!ENTITY aboutSupport.appBasicsUserAgent "User Agent">
>  <!ENTITY aboutSupport.appBasicsMemoryUse "Memory Use">
> +<!ENTITY aboutSupport.appBasicsServiceWorkers "Registered ServiceWorkers">

Here too.
Attachment #8589934 - Flags: review?(ehsan) → review+
Keywords: checkin-needed
Blocks: 1153292
https://hg.mozilla.org/mozilla-central/rev/94f4dcfd983f
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
http://hg.mozilla.org/mozilla-central/diff/94f4dcfd983f/toolkit/locales/en-US/chrome/global/aboutSupport.dtd
"Registered ServiceWorkers"

The spelling is completely inconsistent with the rest of the strings (I think you missed Ehsan's last note).

# LOCALIZATION NOTE the term "Cache" should not be translated.

Is there a specific reason for this? Because normally "cache" is localized
http://transvision.mozfr.org/string/?entity=browser/chrome/browser/sanitize.dtd:itemCache.label&repo=aurora
Flags: needinfo?(amarchesini)
Blocks: 1153805
Flags: needinfo?(amarchesini)
L10n note for b2gtitle (from aboutServiceWorkers.properties) from rev 94f4dcfd983f should be improved or removed like the rest of l10n notes from that patch (as plain wrong and out of place).
(In reply to Stefan Plewako [:stef] from comment #19)
> L10n note for b2gtitle (from aboutServiceWorkers.properties) from rev
> 94f4dcfd983f should be improved or removed like the rest of l10n notes from
> that patch (as plain wrong and out of place).

Can you please clarify what needs to change in the l10n notes for b2gtitle?  Thanks!
(In reply to :Ehsan Akhgari (not reading bugmail, needinfo? me!) from comment #20)
> Can you please clarify what needs to change in the l10n notes for b2gtitle?

> +# LOCALIZATION NOTE the terms "AppId" and "InBrowserElement" should not be translated.
> +b2gtitle = Firefox OS AppID %S - InBrowserElement %S

Argument ordering (%S vs %n$S) should be allowed or explanation why it is not possible should be palced in l10n note. AppId, InBrowserElement doesn't sound like proper nouns, so either localization should be allowed or explanation should be provided about what it actually represents. Also I'm not sure if you wouldn't want to replace "Firefox OS" with sth like brandShortName and if not, add sth about reasoning.
Depends on: 1158361
Thanks a lot, Stefan!  Filed bug 1158361.
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: