Closed Bug 214447 Opened 21 years ago Closed 21 years ago

Shorten attribute and method names in nsIAccessible

Categories

(Core :: Disability Access APIs, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: aaronlev, Assigned: aaronlev)

Details

(Keywords: access)

Attachments

(1 file, 3 obsolete files)

A lot of names in nsIAccessible have "acc" in them, e.g.:
GetAccFirstChild(), AccGetBounds(), GetAccActionName()

This bugs is to get rid of the "acc" - it's redundant since we're already using
nsIAccessible, e.g.:
GetFirstChild(), GetBounds(), GetActionName()
Comment on attachment 128854 [details] [diff] [review]
Remove "acc" from attrib and method names in nsIAccessible

looks great!

the "getFromXXX" method names are a bit odd to me - maybe you want
getLeftNode() or something? I think its "get from" that bothers me... anyhow,
sr=alecf on this because its good stuff, but if you want to change those
methods too, the sr= still applies.
Attachment #128854 - Flags: superreview+
Okay, I'm going to put up a new patch though.

I found a problem when compiling under Linux:

nsIAccessible::GetParent, GetPreviousSibling, GetNextSibling, GetFirstChild,
GetLastChild all now conflict with the same method names in nsIAccessNode.

See,
nsAccessible inherits from nsAccessNode and implements both nsIAccessible and
nsIAccessNode.

Therefore, the method names need to be different -- they navigate relatived to
the accessible tree or the access node tree.

The architecture is documented here:
http://www.mozilla.org/projects/ui/accessibility/accessible-architecture.html
Alec, wouldn't GetAccessibleFrom[Left/Right/Above/Below]() be better?

I'm concerned that if we use the term node people might forget that we're not
talking about DOM nodes.
Also, that way we we wouldn't end up with GetAboveNode(), which sounds strange
to me.
node/accessible/whatever, just as long as it isn't "acc" :)

My big issue with the word "accessible" is that its an adjective, not a noun..
but I guess that's maybe something for a different rewrite of these interfaces :)
Alec, The term "accessible" has historically been used as a noun in
accessibility interfaces.
Attached patch Fixes alecf and gcc's issues (obsolete) — Splinter Review
Attachment #128854 - Attachment is obsolete: true
Attached patch Hmm, last patch was corrupted (obsolete) — Splinter Review
Attachment #128881 - Attachment is obsolete: true
Attachment #128883 - Attachment is obsolete: true
Attachment #128887 - Flags: superreview?(alecf)
Attachment #128887 - Flags: review?(kyle.yuan)
Attachment #128887 - Flags: superreview+
Comment on attachment 128887 [details] [diff] [review]
Fixes last GCC warnings

Carried sr=alecf
Attachment #128887 - Flags: superreview?(alecf)
Comment on attachment 128887 [details] [diff] [review]
Fixes last GCC warnings

I like the new name - less is more.
r=kyle
Attachment #128887 - Flags: review?(kyle.yuan) → review+
thanks everyone. checked in.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: