Closed
Bug 240919
Opened 21 years ago
Closed 21 years ago
warning: `void* nsToolkitWindowProc(long unsigned int, long unsigned int, void*, void*)' declared `static' but never defined
Categories
(Core Graveyard :: GFX: OS/2, defect)
Tracking
(Not tracked)
RESOLVED
FIXED
People
(Reporter: timeless, Assigned: mkaply)
Details
Attachments
(2 files, 2 obsolete files)
20.53 KB,
text/garbage
|
Details | |
14.93 KB,
patch
|
jhpedemonte
:
review+
|
Details | Diff | Splinter Review |
E:/OS2_2.45_Clobber/mozilla/widget/src/os2/nsToolkit.h:87: warning: `void*
nsToolkitWindowProc(long unsigned int, long unsigned int, void*, void*)'
declared `static' but never defined
Assignee | ||
Comment 1•21 years ago
|
||
Please don't start opening bugs on OS/2 warnings. GCC puts way too many warning
errors for us to have bugs for them all.
this unfortunately has a pref cleanup patch, but it can be excised.
Assignee: mkaply → timeless
Status: NEW → ASSIGNED
Attachment #146465 -
Attachment description: diffs from boffo tinderbox → ie doesn't seem to understand the concept of "saving" a remote resource to disk. it seems to think that i wanted it to do some "munging". otoh mozilla just gives me errors.
Attachment #146465 -
Attachment is patch: false
Attachment #146465 -
Attachment mime type: text/plain → text/garbage
Comment on attachment 146466 [details] [diff] [review]
diffs from boffo tinderbox
ignore (prefs):
>Index: gfx/src/os2/nsDeviceContextOS2.cpp
>@@ -46,13 +46,15 @@
>@@ -90,17 +92,15 @@ nsDeviceContextOS2::~nsDeviceContextOS2(
>@@ -118,22 +118,21 @@ nsresult nsDeviceContextOS2::Init( nsNat
>@@ -586,27 +585,35 @@ nsDeviceContextOS2::SetDPI(PRInt32 aPref
>Index: gfx/src/os2/nsDeviceContextOS2.h
ignore (prefs):
>@@ -77,12 +77,14 @@ public:
review class change:
>@@ -122,12 +124,10 @@ public:
review:
>Index: gfx/src/os2/nsDeviceContextSpecOS2.cpp
>@@ -693,13 +693,13 @@ PRINTDLG::PRINTDLG ()
>Index: gfx/src/os2/nsDeviceContextSpecOS2.h
>@@ -75,13 +75,13 @@ class PRTQUEUE;
>Index: gfx/src/os2/nsFontMetricsOS2.cpp
this change is errant (sorry):
>@@ -1,7 +1,7 @@
ignore (prefs):
>@@ -36,13 +36,15 @@
>@@ -64,13 +66,12 @@
>@@ -79,13 +80,13 @@ static NS_DEFINE_CID(kLocaleServiceCID,
>@@ -147,13 +148,13 @@ static nsCharsetInfo gCharsetInfo[eChars
>@@ -188,15 +189,14 @@ NS_IMETHODIMP nsFontCleanupObserver::Obs
review:
>@@ -410,19 +410,19 @@ nsFontMetricsOS2::SetFontHandle(HPS aPS,
ignore (prefs):
>@@ -1056,32 +1056,37 @@ AppendGenericFontFromPref(nsString& aFon
>@@ -1329,34 +1334,36 @@ nsFontMetricsOS2::RealizeFont()
>@@ -1619,45 +1626,46 @@ UnicodeFontEnumCallback(const nsString&
ignore (resource failure):
>@@ -1679,12 +1687,16 @@ nsFontMetricsOS2::FindUnicodeFont(HPS aP
review:
>Index: gfx/src/os2/nsImageOS2.cpp
>@@ -107,21 +107,21 @@ PRBool nsImageOS2::gBlenderReady = PR_F
>@@ -871,12 +871,13 @@ NS_IMETHODIMP nsImageOS2::DrawTile(nsIRe
>Index: widget/src/os2/nsToolkit.cpp
>@@ -37,12 +37,15 @@
>Index: widget/src/os2/nsToolkit.h
>@@ -80,15 +80,12 @@ protected:
Attachment #146466 -
Flags: review?(mkaply)
Assignee | ||
Comment 5•21 years ago
|
||
Comment on attachment 146466 [details] [diff] [review]
diffs from boffo tinderbox
I'll post a new patch for all the warnings in widget
Attachment #146466 -
Flags: review?(mkaply) → review-
Assignee | ||
Comment 6•21 years ago
|
||
Here's a diff that fixes all warnings and removes some dead code.
Assignee: timeless → mkaply
Attachment #146466 -
Attachment is obsolete: true
Assignee | ||
Updated•21 years ago
|
Attachment #146692 -
Flags: review?(pedemont)
Comment 7•21 years ago
|
||
Comment on attachment 146692 [details] [diff] [review]
Complete warning fix for widget
- mRC = DispatchFocus(NS_GOTFOCUS, PR_TRUE);
+ DispatchFocus(NS_GOTFOCUS, PR_TRUE);
Why did you make this change? That function returns mRC. Also, please rename
that variable, since it is not a class member.
In nsToolkit.h, did you want to keep that DEBUG printf?
+// UCHAR uchScan = CHAR4FROMMP(mp1);
Why not just remove this?
Assignee | ||
Comment 8•21 years ago
|
||
> - mRC = DispatchFocus(NS_GOTFOCUS, PR_TRUE);
> + DispatchFocus(NS_GOTFOCUS, PR_TRUE);
> Why did you make this change? That function returns mRC. Also, please rename
> that variable, since it is not a class member.
because mRC that comes back from DispatchFocus is a boolean, not an MRESULT.
I'll just case it.
The mRC name was lifted from nsWindow.cpp.
> In nsToolkit.h, did you want to keep that DEBUG printf?
Nope, I'll remove it.
> +// UCHAR uchScan = CHAR4FROMMP(mp1);
> Why not just remove this?
We might need to get the scan code in the future to fix the DOM_ key bug, so I'd
like to keep it around so I remember how to do it :)
Assignee | ||
Comment 9•21 years ago
|
||
Attachment #146692 -
Attachment is obsolete: true
Assignee | ||
Updated•21 years ago
|
Attachment #146692 -
Flags: review?(pedemont)
Assignee | ||
Updated•21 years ago
|
Attachment #146714 -
Flags: review?(pedemont)
Comment 10•21 years ago
|
||
Comment on attachment 146714 [details] [diff] [review]
New diff addressing Javier's comments
Change 'mrRC' to something like 'mresult'. Otherwise, r=pedemonte
Attachment #146714 -
Flags: review?(pedemont) → review+
Assignee | ||
Comment 11•21 years ago
|
||
Fix checked in.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Updated•16 years ago
|
Product: Core → Core Graveyard
You need to log in
before you can comment on or make changes to this bug.
Description
•