Closed
Bug 42634
Opened 25 years ago
Closed 22 years ago
nsSliderFrame::GetContentOf hides inherited method
Categories
(Core :: Layout, defect, P3)
Tracking
()
RESOLVED
FIXED
Future
People
(Reporter: Brade, Assigned: marc.loiselle)
References
Details
(Whiteboard: [good first bug])
Attachments
(1 file, 2 obsolete files)
6.61 KB,
patch
|
dbaron
:
review+
bryner
:
superreview+
|
Details | Diff | Splinter Review |
on the Macintosh tinderbox Warning page, I see these warnings which should be
investigated:
nsSliderFrame::GetContentOf(nsIBox *, nsIContent **)' hides inherited virtual
function 'nsBoxFrame::GetContentOf(nsIContent **)
Comment 3•25 years ago
|
||
moving all evaughan non-nsbeta3+ bugs to Future milestone, per trudelle
Target Milestone: M20 → Future
![]() |
||
Comment 4•22 years ago
|
||
Just renaming the method would make the warning go away (and make things
clearer, imo).
Whiteboard: [good first bug]
Assignee | ||
Comment 5•22 years ago
|
||
Rename nsSliderFrame::GetContentOf to nsSliderFrame::GetContentOfScrollbar.
The method is private is only used by nsSliderFrame.cpp.
Assignee | ||
Updated•22 years ago
|
Attachment #124149 -
Flags: superreview?(bryner)
Attachment #124149 -
Flags: review?(dbaron)
Comment 6•22 years ago
|
||
Comment on attachment 124149 [details] [diff] [review]
Removes "GetContentOf is hidden" warning
I'd prefer "GetContentForBox" since that's what the function does.
Attachment #124149 -
Flags: superreview?(bryner) → superreview-
Assignee | ||
Comment 7•22 years ago
|
||
GetContentOfBox() instead of GetContentOf() to fix compiler warning
Attachment #124149 -
Attachment is obsolete: true
Assignee | ||
Updated•22 years ago
|
Attachment #124245 -
Flags: superreview?(bryner)
Attachment #124245 -
Flags: review?(dbaron)
Assignee | ||
Updated•22 years ago
|
Attachment #124149 -
Flags: review?(dbaron)
Comment on attachment 124245 [details] [diff] [review]
Removes "GetContentOf is hidden" warning v2
I don't see any reason for this to be a (non-static) member function -- it just
means you're passing around an extra |this| pointer that you don't need.
However, why should it be a member at all? How about:
static already_AddRefed<nsIContent>
ContentOfBox(nsIBox *aBox)
{
nsIFrame *frame;
aBox->GetFrame(&frame);
nsIContent *content;
frame->GetContent(&content);
return content;
}
Assignee | ||
Comment 9•22 years ago
|
||
Add static GetContentOfBox() function. Remove nsSliderFrame::GetContentOf().
Attachment #124245 -
Attachment is obsolete: true
Assignee | ||
Updated•22 years ago
|
Attachment #124313 -
Flags: superreview?(bryner)
Attachment #124313 -
Flags: review?(dbaron)
Assignee | ||
Updated•22 years ago
|
Attachment #124245 -
Flags: superreview?(bryner)
Attachment #124245 -
Flags: review?(dbaron)
Attachment #124313 -
Flags: review?(dbaron) → review+
Updated•22 years ago
|
Attachment #124313 -
Flags: superreview?(bryner) → superreview+
Assignee | ||
Comment 10•22 years ago
|
||
dbaron, Can you check-in for me?
.
Assignee: eric → mloiselle
Status: ASSIGNED → NEW
Fix checked in to trunk, 2003-06-01 19:39 -0700.
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → FIXED
You need to log in
before you can comment on or make changes to this bug.
Description
•