[OSX HiDPI] .close-icon width not set, making Add-on SDK toolbar close icons huge

VERIFIED FIXED in Firefox 30

Status

()

defect
VERIFIED FIXED
5 years ago
Last year

People

(Reporter: Gijs, Assigned: Gijs)

Tracking

unspecified
mozilla32
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox30 verified, firefox31 verified, firefox32 verified)

Details

(Whiteboard: [qa+] )

Attachments

(2 attachments)

Assignee

Description

5 years ago
Posted image Screenshot
We currently just set width: for the consumers, like the tab and sidebar close buttons, but I think we should just set it in the 2ddpi media query block inside the toolkit theme.
Assignee

Updated

5 years ago
Summary: .close-icon width not set, making Add-on SDK toolbar close icons huge → [OSX HiDPI] .close-icon width not set, making Add-on SDK toolbar close icons huge
Assignee

Updated

5 years ago
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
See Also: → 1008594
Assignee

Comment 1

5 years ago
This also fixes bug 1008594.
Attachment #8421057 - Flags: review?(dao)
Assignee

Updated

5 years ago
Blocks: 1008594
Attachment #8421057 - Flags: review?(dao) → review+
Assignee

Comment 2

5 years ago
remote:   https://hg.mozilla.org/integration/fx-team/rev/16276ce2ff1a
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/16276ce2ff1a
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla32
Assignee

Updated

5 years ago
Assignee

Comment 4

5 years ago
Comment on attachment 8421057 [details] [diff] [review]
fix hidpi close icon size,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): close-icon consolidation and/or SDK sidebars/toolbars
User impact if declined: sidebars and SDK toolbars have huge close icons
Testing completed (on m-c, etc.): on m-c, local
Risk to taking this patch (and alternatives if risky): low, CSS-only
String or IDL/UUID changes made by this patch: none
Attachment #8421057 - Flags: approval-mozilla-beta?
Attachment #8421057 - Flags: approval-mozilla-aurora?
Attachment #8421057 - Flags: approval-mozilla-beta?
Attachment #8421057 - Flags: approval-mozilla-beta+
Attachment #8421057 - Flags: approval-mozilla-aurora?
Attachment #8421057 - Flags: approval-mozilla-aurora+
Whiteboard: [qa+]
No longer blocks: 1008594
See Also: 1008594
Duplicate of this bug: 1008594
Juan, I know you've verified other Retina specific bugs before... do you think you or someone on your side could also verify this?

On Windows (normal and HiDPI) I've seen some other UI issues related to this add-on, but none related to the Close button.
Flags: needinfo?(jbecerra)
I checked this on a MB with Retina display as well as a Surface Pro 2, using latest 30, 31, 32. Sidebar buttons do not look huge.
Assignee

Comment 10

5 years ago
Marking verified per comment #9.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.