Closed Bug 1000114 Opened 6 years ago Closed 6 years ago

Extend test coverage for experiments in addon manager UI

Categories

(Firefox Health Report Graveyard :: Client: Desktop, defect)

defect
Not set

Tracking

(firefox31 fixed, firefox32 fixed)

VERIFIED FIXED
Firefox 32
Tracking Status
firefox31 --- fixed
firefox32 --- fixed

People

(Reporter: gfritzsche, Assigned: gfritzsche)

References

Details

(Whiteboard: p=3 s=it-32c-31a-30b.2 [qa-])

Attachments

(1 file, 1 obsolete file)

We need to extend the test coverage for experiments in addon manager UI to cover the details added in bug 986677 and for the refresh in bug 992258.
Flags: firefox-backlog?
Flags: firefox-backlog? → firefox-backlog+
Assignee: nobody → georg.fritzsche
Status: NEW → ASSIGNED
Whiteboard: p=3 s=it-32c-31a-30b.1 [qa?]
The refresh parts should be handled by bug 992258 already.
Blair, i was wondering today - what do you think we are missing for test coverage for bug 986677? Testing for the presence of the UI elements?
Flags: needinfo?(bmcbride)
Whiteboard: p=3 s=it-32c-31a-30b.1 [qa?] → p=3 s=it-32c-31a-30b.1 [qa-]
* Presence of the new elements
* Absence of the ones purposefully hidden
* Check the text displayed for various scenarios for the time remaining/time ago element is as expected (but *only* for the en-US locale - so you can hard-code the strings in the test)
Flags: needinfo?(bmcbride)
Attached patch Extend test coverage (obsolete) — Splinter Review
I'm flagging both Irving & Unfocused for review for whoever has time first.
Attachment #8419533 - Flags: review?(irving)
Attachment #8419533 - Flags: review?(bmcbride)
Attachment #8419533 - Flags: review?(irving)
Attachment #8419533 - Flags: review?(bmcbride)
Attachment #8419533 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/674c36d744fb
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
Turns out something in this push was causing frequent browser_experiments.js failures on OSX 10.8 opt builds. Backed out.
https://hg.mozilla.org/mozilla-central/rev/7586c29906b5

https://tbpl.mozilla.org/php/getParsedLog.php?id=39384864&tree=Fx-Team
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: Firefox 32 → ---
Looking through this, elements are sometimes not instantiated yet, so apparently there are issues around XBL instantiation etc. Other tests for the addon manager fix this by making sure the node is visible:
http://hg.mozilla.org/mozilla-central/annotate/a8602e656d86/toolkit/mozapps/extensions/test/browser/browser_bug562854.js#l50

This fixes things locally, pushed to try:
https://tbpl.mozilla.org/?tree=Try&rev=bb6b8b6ffa09
Whiteboard: p=3 s=it-32c-31a-30b.1 [qa-] → p=3 s=it-32c-31a-30b.2 [qa-]
https://hg.mozilla.org/mozilla-central/rev/a98ed6c91bf3
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
Status: RESOLVED → VERIFIED
[Approval Request Comment]
Bug caused by (feature/regressing bug #): Telemetry experiments.
User impact if declined: Missing test-coverage for bug 986677.
Testing completed (on m-c, etc.): Fine on m-c.
Risk to taking this patch (and alternatives if risky): Low/none - just test-coverage.
String or IDL/UUID changes made by this patch: None.
Attachment #8419533 - Attachment is obsolete: true
Attachment #8423900 - Flags: approval-mozilla-aurora?
Attachment #8423900 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Firefox Health Report → Firefox Health Report Graveyard
You need to log in before you can comment on or make changes to this bug.