Closed Bug 1000157 Opened 7 years ago Closed 6 years ago

Desktop client needs ability to go full screen in a call.

Categories

(Hello (Loop) :: Client, enhancement, P4)

enhancement

Tracking

(Not tracked)

RESOLVED WONTFIX
Blocking Flags:
backlog backlog+

People

(Reporter: RT, Unassigned)

References

Details

User Story

As a FF browser user in a call I can go full screen so that I can see the other person better.

See comment 2 for suggested UX.

Attachments

(1 file)

No description provided.
User Story: (updated)
Priority: -- → P3
Whiteboard: [s=ui32]
Target Milestone: --- → mozilla32
Priority: P3 → P1
Whiteboard: [s=ui32] → [p=?]
Target Milestone: mozilla32 → mozilla34
Target Milestone: mozilla34 → mozilla35
Flags: firefox-backlog+
Priority: P1 → P2
What's the UX here? There's no button on the call ui for going full-screen.

https://people.mozilla.org/~dhenein/labs/loop-mvp-spec/#call-active

The only button we seem to have is the one for popping out into the separate window.

On Mac this can be expanded to full screen, on other platforms, we can only make the window full-size.

We'll also need the layout for the window if it is anything different to the current conversation window (though I'm assuming not).
Flags: needinfo?(dhenein)
Whiteboard: [p=?] → [needs UX]
Blocks: 1012743
Severity: normal → enhancement
Ya, this was supposed to be in 35 and not part of the MVP, so it's not in there. I would suggest using the same icon as https://people.mozilla.org/~dhenein/labs/loop-link-spec/#video-call (top right) but put it in the toolbar in the same style as the mic/video buttons. Let me know if thats enough or if you want a mockup to show you.
Flags: needinfo?(dhenein)
User Story: (updated)
Whiteboard: [needs UX]
backlog: --- → Fx38?
Target Milestone: mozilla35 → ---
backlog: Fx38? → Fx39?
Duplicate of this bug: 1115360
Sevaan, I think you had UX for this somewhere although I can't find it?
Flags: needinfo?(sfranks)
Bug 1087938 - [UX] Design UX for full screen mode on link clicker UI
Flags: needinfo?(sfranks)
(In reply to Sevaan Franks [:sevaan] from comment #5)
> Bug 1087938 - [UX] Design UX for full screen mode on link clicker UI

Thanks but that's the link clicker although this bug is about desktop client UI. Do we have UX for the desktop client UI full screen feature?
Hey Romain, it's included in the same bug. See the attachment: https://bug1087938.bugzilla.mozilla.org/attachment.cgi?id=8534565
Pulled the spec out of the link clicker bug.
Thanks :)
backlog: Fx39? → Fx38+
Priority: P2 → P4
backlog: Fx38+ → backlog+
Rank: 45
Resolving as WON'T FIX since full screen video is not relevant anymore for Websharing (focus on web content shared).
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.