Closed Bug 1000197 Opened 7 years ago Closed 7 years ago

Desktop client needs "call terminated" visual and audio notifications

Categories

(Hello (Loop) :: Client, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED WONTFIX
33 Sprint 3- 7/21

People

(Reporter: RT, Assigned: dmose)

References

Details

(Whiteboard: [p=2])

User Story

As a FF browser user in a call (signed-in or not), I get notified "Call terminated" if the other party terminates the call
As a FF browser user in a call (signed-in or not), I get notified "Call terminated" if the other party closes his browser
As a FF browser user in a call (signed-in or not), I get notified "Call terminated" if the other party loses Internet connection
No description provided.
User Story: (updated)
Summary: Desktop client needs "call terminated visual and audio notification → Desktop client needs "call terminated" visual and audio notification
User Story: (updated)
Blocks: 1000788
No longer blocks: 972017
Priority: -- → P1
Summary: Desktop client needs "call terminated" visual and audio notification → Desktop client needs "call terminated" visual notification
Target Milestone: --- → mozilla32
Whiteboard: [s=ui32]
Priority: P1 → P2
Whiteboard: [s=ui32] → [p=?]
Priority: P2 → P1
Target Milestone: mozilla32 → mozilla33
the TB toolkit has this capabilities - but need UX.  right now just displaying rectangles if disconnected.  look at last UX in darrins as Call Failed (similar to what call terminated will look like)
Whiteboard: [p=?] → [p=2]
Summary: Desktop client needs "call terminated" visual notification → Desktop client needs "call terminated" visual and audio notifications
Duplicate of this bug: 1006515
This bug tracks all potential scenarios causing a call to terminate which can occur when a call is established. This for now assumes a common "call terminated" UX.
User Story: (updated)
User Story: (updated)
Darrin, this bug is for a desktop client user who is on a call which gets terminated.
The closest UX you have is https://people.mozilla.org/~dhenein/labs/loop-mvp-spec/#call-ended although in a scenario where a desktop client user is in a call with a link clicker he has no way to call back the user.
Should we therefoire just disable the "call-back" button in this scenario or should we not display it?
Flags: needinfo?(dhenein)
If it's from a link-clicker, don't display the Call Back button.
Flags: needinfo?(dhenein)
Assignee: nobody → dmose
Target Milestone: mozilla33 → 33 Sprint 3- 7/21
https://github.com/dmose/gecko-dev/pull/3 has my work-in-progress.  Still needs a bunch of work, but looking straightforward.  Based on Niko's Reactified conversation view branch.
WIP is now at https://github.com/dmose/gecko-dev/pull/4

My marginally readable notes that I've been keeping as I go are at <https://webrtc.etherpad.mozilla.org/terminated-call>.
After discussions with Darrin, we'll skip the call terminated screen and implement only the user feedback screen with a call back button along side the report user button (https://bugzilla.mozilla.org/show_bug.cgi?id=972992). 

This is pending UX amendment from Darrin.
Just talked to Darrin; we're abandoning this view.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.