Closed Bug 1000356 Opened 5 years ago Closed 2 years ago

[B2G][Tarako][Lockscreen]Status bar time (minutes) not consistently in sync with lockscreen time with SIM Card inserted and after battery reinserted in device

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3 affected, b2g-v1.3T affected)

RESOLVED WONTFIX
Tracking Status
b2g-v1.3 --- affected
b2g-v1.3T --- affected

People

(Reporter: mclemmons, Unassigned)

References

()

Details

(Whiteboard: [tarako-exploratory])

Attachments

(2 files)

Attached file Firewatch Log
User reinserts battery in device with an active SIM card. User turns on device and observes the phone starting up and the Lockscreen page displays with the status bar time in the upper right and the incorrect (hour and minute) time on top of the wallpaper. Once the incorrect time on top of the wallpaper syncs to the correct time, so it appears, one observes that there is anywhere from a 2 to 28 second delay between the status bar time and the time over the wallpaper. For example, once the status bar time changes from 10:16 am to 10:17 am, it takes 2 to 28 seconds before the time on top of the wallpaper changes to 10:17 am. (In youtube video, you can fast forward to the one minute and 50 second mark for a demonstration.) 

Prerequisites:
1. Have an active SIM inserted in device
2. Take Battery out of device and reinsert 

Repro Steps: 
1) Updated Tarako to BuildID: 20140423024002
2) Turn device on
3) Observe both the clock in the status bar as well as the clock above the wallpaper screen for over a minute but less than two minutes.

Actual: 
There is a short to significant delay in the minutes of the clock on top of the wallpaper. (ranges from 2 to 28 seconds).
 
Expected: 
Both clocks react in sync with at worst a 1 second delay between the times. 

Repro rate: 18/20 = 90 percent
Attached, logcat, firewatch, video clip = https://www.youtube.com/watch?v=gr36EbBkTps
Notes: There seemed to be improvement in syncing when the device was charging through a USB connection with a computer, thus the two successes in the above repro rate. But inconsistency returned after further testing. 

Environmental Variables: 
Device: Tarako 1.3T MOZ 
BuildID: 20140422014001 
Gaia: e87f8a69a2bad4a1361529b180a4e015fc78fbf1 
Gecko: 1350653d7e40 
Version: 28.1
Firmware version: sp6821a_gonk4.0_user.pac
Correction to comment 0 - updated Environmental Variables

Environmental Variables:
Device: Tarako 1.3T MOZ
BuildID: 20140423014003
Gaia: 9aa9b04049f0291b124c50e0f9c3ce0e1f547725
Gecko: 5dc3e5ec4178
Version: 28.1
Firmware Version: sp6821a_gonk4.0_user.pac
This issue does reproduce on 1.3 Buri. Following the STR in Comment 0 does display the inconsistency in the syncing between the device times. Time differences averaged 15-20 seconds. 

Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140423024002
Gaia: fb2b8e25e8095a5db49b5eb68c74b49f180605d4
Gecko: da2500909f91
Version: 28.0
Firmware version: v1.2-device.cfg
Attached file Logcat Time Issue
As far as I understand it, the set automatically for the time/date depends on wifi or SIM connection... so the fact that it auto corrects itself shows that the automatic time adjustment works.

Having said, that... not sure why one time gets lost while the other time doesn't.
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.