Mozilla is unable to render very large forms (700K)

VERIFIED DUPLICATE of bug 6048

Status

()

P3
normal
VERIFIED DUPLICATE of bug 6048
20 years ago
19 years ago

People

(Reporter: robertson, Assigned: pollmann)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
The company I work for has a very large web interface.  Many of the forms for
our site are over 700 kilobytes in size.  I have not been able to render any of
these largest forms in any mozilla version.  I have tried m3, m5-8.  m3 would
actually crash the X-Windows system on my computer when I tried.  m5-8 just
never render it, but take up all of the processor and memory attempting to.

I am running RedHat 6.0 with Linux kernel 2.2.10.  GTK+ 2.2.3.  I have a
p166-MMX and 64 meg ram.

These forms render with Netscape communicator on Macintosh, Linux, windows NT,
but not Windows 3.1/95/98.

If you want a copy of a form that will freeze Mozilla (they are nothing but
standard HTML).  Please email me at robertson@rocketmail.com

Updated

19 years ago
Assignee: rickg → pollmann

Comment 1

19 years ago
Eric-- please dig into this to see where the problem is. It could be forms
related, or it may just be layout related.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Component: Viewer App → Layout
Resolution: --- → DUPLICATE
Target Milestone: M9

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 2

19 years ago
known bug

*** This bug has been marked as a duplicate of 6048 ***
(Assignee)

Comment 3

19 years ago
I received a test form from Andy.  I agree with Jan, this is a dup of bug 6048.

I was able to view this form and scroll down it in today's Necko apprunner.
However, loading and laying out the page consumed 198M of memory and took 7
minutes to display.  This was on my Pentium II 266 Linux box (RH5.2 + Kernel
2.2.1-5) with 128 Megs of RAM and two 256Mb swap partitions.  I didn't
experience any crashes or X problems but bad things would have happened if I
didn't have this much swap space or patience.
(Assignee)

Comment 4

19 years ago
Actually, it was only consuming 72Mb of memory, the 198Mb figure included shared
libraries, buffers, cache, ...
You need to log in before you can comment on or make changes to this bug.