Closed Bug 1000580 Opened 6 years ago Closed 4 years ago

[B2G][Tarako][Settings][Date & Time] Occasionally in the Date & Time settings, the 'Set Automatically" option is not present

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3T affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v1.3T --- affected

People

(Reporter: jcastro, Unassigned)

Details

(Whiteboard: [tarako-exploratory])

Attachments

(4 files)

Attached file Date_Time_Logcat.txt
Description:
The user turned WIFI off, and restarted the DUT. User went to settings > Date & Time. User noticed the "Set Automatic" text, and Toggle switch are not present.

Repro Steps:
1) Update a tarako to BuildID: 20140423014003
2) Go into settings > Turn on airplane mode
3) Restart the phone
4) Go into settings > Date & Time

Actual:
The "Set Automatically" text and toggle switch at not always present

Expected:
The option is always present. If the option cannot be used it is greyed out. 

1.3t Environmental Variables:
Device: tarako 1.3t MOZ
BuildID: 20140423014003
Gaia: 9aa9b04049f0291b124c50e0f9c3ce0e1f547725
Gecko: 5dc3e5ec4178
Version: 28.1
Firmware Version: Sp6821a-4-18

Repro frequency: 40%
See attached: Screenshot, Logcat, Firewatch
Can get it to occur briefly on buri. The text and switch draws in after the rest of the menu the first time its accessed. Possibly a different bug.

Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140423024002
Gaia: fb2b8e25e8095a5db49b5eb68c74b49f180605d4
Gecko: da2500909f91
Version: 28.0
Firmware version: v1.2-device.cfg

Video of Buri on v1.3 behavior:
http://youtu.be/UhWeM6ISXZU
Summary: [Tarako][Settings][Date & Time] Occasionally in the Date & Time settings, the 'Set Automatically" option is not present → [B2G][Tarako][Settings][Date & Time] Occasionally in the Date & Time settings, the 'Set Automatically" option is not present
Whiteboard: [tarako-exploratory]
Attached image 2012-03-21-15-02-33.png
Can we get videos here showcasing behavior differences on 1.3 vs. 1.3T?
Keywords: qawanted
Spoke with the reporter and we found that this issue actually appears to occur 100% of the time on both Buri 1.3 and Tarako 1.3T. 

The 'Set automatically' setting is not present when there aren't any network connections available to retrieve the time. Once airplane mode is disabled and/or a network connection is established (whether through cellular data or WiFi), the setting appears. 

Therefore this looks to be by design, but having the option present and grayed out is what was expected since a user may not even know it's there in certain situations.

Attached a video comparing Buri 1.3 to Tarako 1.3T, which both actually exhibit the same behavior.
Keywords: qawanted
It is as designed, when either automatic time sources are not avaliable (NITZ from GSM network or NTP from Wifi network), "Set Automatically" option will not be displayed.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.