Closed Bug 1000649 Opened 10 years ago Closed 10 years ago

[Sora][Settings][BT][Music]Music put outside when disconnect BT headset

Categories

(Firefox OS Graveyard :: Gaia::Music, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1037359

People

(Reporter: sync-1, Unassigned)

References

Details

Attachments

(1 file)

33.75 KB, application/octet-stream
Details
Firefox OS v1.3
 Mozilla build ID:20140404164003
 
 DEFECT DESCRIPTION:
 Music put outside when disconnect BT headset
 
  REPRODUCING PROCEDURES:
 1.use BT headset listen to music
 2.disconnect BT headset
 3.music put outside one time--K.O
 
 Note:
 
  EXPECTED BEHAVIOUR:
 K.O--Music should pause when disconnect BT headset
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:medium
 
  REPRODUCING RATE:5/5
 
  For FT PR, Please list reference mobile's behavior:
Attached file jrdlog
From Qualcomm:

New Comment: From the log, we have:
Device is switched from A2DP to speaker at 16:58:01.841, before that, at 16:58:01.661 the Gecko bluetooth module was notified of the disconnect even though it didn’t fully process the event until 16:58:02.001. So it looks like there is an in-Gecko latency that Mozilla needs to address.
If you feel this is important for Mozilla to fix, you probably should raise it through the Mozilla TAM.
Hi Vance,

Would you please push this issue, QC case(No 01532036) will be closed soon, and QC engineer said it's mozilla side issue, please refer to comment#2.

Thanks.
Flags: needinfo?(vchen)
Hi Vance,

Customer may block on this issue, please help push it.

Thanks.
Hi Shawn -

I remembered when we discussed this before, is it possible we can enhance the behavior in later release?

Thanks
Flags: needinfo?(vchen) → needinfo?(shuang)
Solution is ready and under review, you might want to cherry-pick this patch.
See: https://bugzilla.mozilla.org/show_bug.cgi?id=1037359
Flags: needinfo?(shuang)
See Also: → 1037359
[Blocking Requested - why for this release]:set blocking flag to make sure patch landing on 2.0, thanks.
blocking-b2g: --- → 2.0?
[Blocking Requested - why for this release]:
blocking-b2g: 2.0? → 2.1?
Whiteboard: 1062757
Whiteboard: 1062757
Component: Gaia → Gaia::Music
Looks like a dup of bug 1037359 according to comment 6.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate, clearing flag.
blocking-b2g: 2.1? → ---
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: