Closed Bug 1000758 Opened 5 years ago Closed 5 years ago

Fix -Wunused-const-variable warnings in mfbt/tests

Categories

(Core :: MFBT, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 807607
Tracking Status
firefox31 --- affected

People

(Reporter: cpeterson, Assigned: cpeterson)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

mfbt/tests/TestBinarySearch.cpp:29:10 [-Wunused-variable] unused variable 'm'
mfbt/tests/TestEndian.cpp:292:24 [-Wunused-variable] unused variable 'unsigned_bytes'
mfbt/tests/TestEndian.cpp:294:23 [-Wunused-variable] unused variable 'signed_bytes'
mfbt/tests/TestEnumSet.cpp:119:24 [-Wunused-variable] unused variable 'seen'
mfbt/tests/TestEnumSet.cpp:151:24 [-Wunused-variable] unused variable 'procellariiformes'
mfbt/tests/TestEnumSet.cpp:166:24 [-Wunused-variable] unused variable 'likes'
mfbt/tests/TestEnumSet.cpp:182:24 [-Wunused-variable] unused variable 'likes'
mfbt/tests/TestEnumSet.cpp:197:24 [-Wunused-variable] unused variable 'likes'
mfbt/tests/TestEnumSet.cpp:204:24 [-Wunused-variable] unused variable 'likes'
mfbt/tests/TestFloatingPoint.cpp:274:11 [-Wunused-variable] unused variable 'i'
mfbt/tests/TestFloatingPoint.cpp:342:11 [-Wunused-variable] unused variable 'i'
mfbt/tests/TestFloatingPoint.cpp:343:17 [-Wunused-variable] unused variable 'BIG'
mfbt/tests/TestFloatingPoint.cpp:375:9 [-Wunused-variable] unused variable 'lessThanEpsilon'
mfbt/tests/TestFloatingPoint.cpp:376:9 [-Wunused-variable] unused variable 'moreThanEpsilon'
mfbt/tests/TestFloatingPoint.cpp:430:9 [-Wunused-variable] unused variable 'oneThird'
mfbt/tests/TestFloatingPoint.cpp:444:10 [-Wunused-variable] unused variable 'lessThanEpsilon'
mfbt/tests/TestFloatingPoint.cpp:445:10 [-Wunused-variable] unused variable 'moreThanEpsilon'
mfbt/tests/TestFloatingPoint.cpp:499:10 [-Wunused-variable] unused variable 'oneThird'
mfbt/tests/TestTypedEnum.cpp:32:16 [-Wunused-const-variable] unused variable 'autoEnum'
mfbt/tests/TestTypedEnum.cpp:33:16 [-Wunused-const-variable] unused variable 'charEnum'
mfbt/tests/TestTypedEnum.cpp:34:24 [-Wunused-const-variable] unused variable 'nestedAutoEnum'
mfbt/tests/TestTypedEnum.cpp:35:24 [-Wunused-const-variable] unused variable 'nestedCharEnum'
Attachment #8411626 - Flags: review?(jwalden+bmo)
Is that with an opt build or a debug build?  You might also get away with making things DebugOnly<>.

I think Benoit was doing sort of the same thing in bug 807607.
Haha, yes, the patch in bug 807607 seems to be exactly the same!

Fun coincidence after 1.5 years of no activity since that bug was filed!
(In reply to Benoit Jacob [:bjacob] from comment #2)
> Haha, yes, the patch in bug 807607 seems to be exactly the same!
> 
> Fun coincidence after 1.5 years of no activity since that bug was filed!

"Given enough eyeballs, all bugs will eventually be duplicated."
Comment on attachment 8411626 [details] [diff] [review]
mfbt_Wunused-const-variable.patch

Review of attachment 8411626 [details] [diff] [review]:
-----------------------------------------------------------------

Cagefight to determine which patch lands.  :-)
Attachment #8411626 - Flags: review?(jwalden+bmo) → review+
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 807607
You need to log in before you can comment on or make changes to this bug.