Closed Bug 1000796 Opened 6 years ago Closed 6 years ago

Fix localization comments for plural forms in extensions.properties

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla31

People

(Reporter: flod, Assigned: gfritzsche)

References

Details

(Whiteboard: p=1 s=it-31c-30a-29b.3 [qa-])

Attachments

(1 file, 1 obsolete file)

We need to fix the localization note associated with plural form
http://hg.mozilla.org/mozilla-central/diff/18c0f7152372/toolkit/locales/en-US/chrome/mozapps/extensions/extensions.properties

Comments for each string should be in the form of

# LOCALIZATION NOTE (STRINGID): Semi-colon list of plural forms.
# See: http://developer.mozilla.org/en/docs/Localization_and_Plurals
# whatever you want to add from this point

It may sounds weird, but those two lines are picked by tools to identify plural forms.
Since we're on the subject, do we really need to duplicate those strings?

Context seems to be absolutely the same (text under the add-on name), so it doesn't seem needed to me.
Flags: needinfo?(georg.fritzsche)
Bug 986677, comment 11, says the contexts are slightly different.
Flags: needinfo?(georg.fritzsche)
Flags: firefox-backlog?
I'm comparing
https://bug986677.bugzilla.mozilla.org/attachment.cgi?id=8403939

and
https://bug986677.bugzilla.mozilla.org/attachment.cgi?id=8403940

Subject is the same (add-on), position is basically the same (under the add-on name), we shouldn't have issues with the available space based on the images, so personally I would use the same strings.
I'll leave that question to Blair, please file a follow-up for this if needed, i'll limit this bug to what we definitely need.
Attached patch Fix (obsolete) — Splinter Review
Assignee: nobody → georg.fritzsche
Status: NEW → ASSIGNED
Attachment #8411705 - Flags: review?(bmcbride)
Attachment #8411705 - Flags: feedback?(francesco.lodolo)
Comment on attachment 8411705 [details] [diff] [review]
Fix

Review of attachment 8411705 [details] [diff] [review]:
-----------------------------------------------------------------

Localization comments look good, but not that this patch contains a lot of other stuff, and some of it look like local testing.
Attachment #8411705 - Flags: feedback?(francesco.lodolo) → feedback+
(In reply to Francesco Lodolo [:flod] from comment #6)
> but not that this patch contains a lot of

"note that", clearly not a good day for me and English.
Thanks - and sorry about the other stuff, hasty patch upload before leaving for lunch.
Attached patch Fix commentsSplinter Review
Attachment #8411705 - Attachment is obsolete: true
Attachment #8411705 - Flags: review?(bmcbride)
Attachment #8411756 - Flags: review?(bmcbride)
Whiteboard: p=1 s=it-31c-30a-29b.3 [qa?]
QA Contact: florin.mezei
Whiteboard: p=1 s=it-31c-30a-29b.3 [qa?] → p=1 s=it-31c-30a-29b.3 [qa+]
Since this is a change in comments from extensions.properties, I don't think there's anything needed from QA, since there is no functional/UI testing involved. Looking at the fix, comments seem to have been modified as intended.

I'm marking this as [qa-]... mark it back as [qa+] if you think there's anything else we should do on the QA side.
Whiteboard: p=1 s=it-31c-30a-29b.3 [qa+] → p=1 s=it-31c-30a-29b.3 [qa-]
Comment on attachment 8411756 [details] [diff] [review]
Fix comments

Review of attachment 8411756 [details] [diff] [review]:
-----------------------------------------------------------------

Huh, ok.

Also, as for using different strings, this was something that was brought up and decided on back in the days of the original rewrite for Firefox 4. For the purposes of bug 986677 and this, consistency and previous assertions over requirements win. Neither that bug nor this is the place to change that. If you think it's worth looking into only having one copy of the strings, can you file a new bug?
Attachment #8411756 - Flags: review?(bmcbride) → review+
https://hg.mozilla.org/mozilla-central/rev/ed6d2e76df44
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
Status: RESOLVED → VERIFIED
Flags: firefox-backlog? → firefox-backlog+
You need to log in before you can comment on or make changes to this bug.