Closed Bug 1000879 Opened 6 years ago Closed 6 years ago

Remove the ::-moz-math-stretchy pseudo-element.

Categories

(Core :: MathML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla31

People

(Reporter: fredw, Assigned: fredw)

References

Details

(Keywords: dev-doc-complete, site-compat)

Attachments

(1 file, 3 obsolete files)

The non-standard ::-moz-math-stretchy pseudo element allows authors to specify a font-family to use for stretchy operators. However, it would be better to just use the font-family inherited from the parent style context, so that one will only need to specify the font-family on the <math> element to choose a math font (for the stretchy op and other math styles read from the OpenType MATH table). At the moment the default style of ::-moz-math-stretchy overrides the one of the parent context, so authors can not avoid using it. For example, it is currently necessary for the MathML torture test: https://mdn.mozillademos.org/en-US/docs/Mozilla/MathML_Project/MathML_Torture_Test$samples/MathML_Torture_Test

I'll try to extract part 2 of bug 947654 reviewed by Karl. However, I got failures when testing it, so I need to check what happens:

https://tbpl.mozilla.org/?tree=Try&rev=c00d382f0cf5
Attached patch Part 1 (obsolete) — Splinter Review
This is attachment 8408288 [details] [diff] [review] reviewed by Karl on bug 947654.
Assignee: nobody → fred.wang
Status: NEW → ASSIGNED
Attached patch Patch (fixing reftests results) (obsolete) — Splinter Review
The patch seems to make mfenced-10.html pass on Windows.

semantics-1.xhtml is a known font-dependent failure (I have had it locally for a while).

The mfenced-10.html and menclose-2-longdiv.html screenshots on Windows XP seems to show that some stretchy glyphs are now built with boxes of "missing unicode code point". The problem is really missing math fonts on the try servers and the results will be correct if appropriate fonts are installed. I try various changes without success so I believe removing this non-standard ::-moz-math-stretchy pseudo-element and encouraging the move to OpenType MATH fonts is more important than trying to make the XP try server work.

(If we keep this ::-moz-math-stretchy, all the demos for the new OpenType MATH fonts that don't use this non-standard syntax won't work)
Attachment #8412136 - Flags: review?(roc)
Attached patch Patch (fixing reftests results) (obsolete) — Splinter Review
Attachment #8412136 - Attachment is obsolete: true
Attachment #8412136 - Flags: review?(roc)
Attachment #8412140 - Flags: review?(roc)
Attached patch PatchSplinter Review
Folding the patches.
Attachment #8411917 - Attachment is obsolete: true
Attachment #8412140 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/4d713f81644d
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
You need to log in before you can comment on or make changes to this bug.