Closed Bug 1000956 Opened 6 years ago Closed 6 years ago

Dictionary is too tight

Categories

(Core :: Spelling checker, defect, minor)

defect
Not set
minor

Tracking

()

RESOLVED FIXED
mozilla32

People

(Reporter: george.bateman16, Assigned: ananuti)

Details

Attachments

(1 file, 1 obsolete file)

I looked at the following words in a textbox:
* online
* underway
* textbox
* coauthors
* sportsperson

Every one received a red underline, which is unreasonable.
http://mxr.mozilla.org/mozilla-central/source/extensions/spellcheck/locales/en-US/hunspell/README_en_US.txt says that the SCOWL dictionary is loaded up to level 60, which http://downloads.sourceforge.net/wordlist/scowl-7.1.zip > README says contains only 18.1% of the words. 
This could probably be rectified by using a higher level, although this is against the README's recommendations.
Level 95 (max) is needed even for "biochemics" and "unconfidential", despite the README statement "No one should need to use a size larger than 80,
the 95 size is labeled insane for a reason."
Component: General → Spelling checker
OS: Windows XP → All
Product: Firefox → Core
Hardware: x86 → All
Version: 28 Branch → Trunk
Sorry, I'm not sure what I was on about with "biochemics"; it isn't a real word. Level 80 seems fine., and we can always tweak it if necessary.
Additionally, how about offering a unified English dictionary? It is rare that anyone using a lot of textboxes will not at some point want British English if they are in the US and American in the UK. (Eg.: editing Wikipedia).
Another plausible source of words would be the titles of all Wikipedia articles that are not redirects.
Let's not try to solve the problem in comment 2 here.  That would be a conversation that I hope to be able to avoid  :-)

Can you please list the words you want to see added here, with a link to a dictionary such as Oxford or Merriam Webster that confirms that someone more authoritative than me considers them to be valid words?  Once you do that, we can get those words added to the dictionary.  Thanks!

(Please note that I'm not a native English speaker myself which is why I'm asking for those links. :-)
Just to be clear, my list was for examples only: what concerns me is that there are many of these cases, not those five in particular. Anyway, the OED says:
* http://www.oxforddictionaries.com/definition/english/online
* Underway: seems to be an Americanism. http://www.oxforddictionaries.com/words/one-word-or-two
* Textbox: seems that I wasn't quite right, not many take it, but if you look at usage in published books it is used: https://books.google.com/ngrams/graph?content=textbox%2Ctext+box&year_start=2007&year_end=2008&corpus=17&smoothing=0&share=&direct_url=t1%3B%2Ctextbox%3B%2Cc0%3B.t1%3B%2Ctext%20box%3B%2Cc0
* co-authors: OED don't have it, but many do: http://www.bing.com/search?q=%2Bcoauthor&pc=MOZI&form=MOZSBR
* http://www.oxforddictionaries.com/definition/english/sportsperson
Perhaps my examples were less correct than they should have been.
Anyway, my impression has always been that there are more red lines marked than there should be. MS Word 2010 flags up only "coauthors" given the list above.
Thanks, George!  Ekanan, are you interested in taking this?
Flags: needinfo?(ananuti)
(In reply to george.bateman16 from comment #0)
> I looked at the following words in a textbox:
> * online
> * underway
> * coauthors
> * sportsperson

added since mozilla 1.9
Assignee: nobody → ananuti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(ananuti)
Attachment #8417140 - Flags: review?(ehsan)
Attachment #8417140 - Attachment is obsolete: true
Attachment #8417140 - Flags: review?(ehsan)
Attachment #8417142 - Flags: review?(ehsan)
Attachment #8417142 - Flags: review?(ehsan) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/bd63c71f0f45
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla32
You need to log in before you can comment on or make changes to this bug.