Closed Bug 1001049 Opened 7 years ago Closed 7 years ago

npm install fails on 1.3t

Categories

(Firefox OS Graveyard :: Gaia, defect)

defect
Not set
normal

Tracking

(b2g-v1.3 fixed, b2g-v1.3T fixed)

RESOLVED FIXED
1.4 S6 (25apr)
Tracking Status
b2g-v1.3 --- fixed
b2g-v1.3T --- fixed

People

(Reporter: mikehenrty, Assigned: mikehenrty)

Details

(Whiteboard: [systemsfe][p=1])

Attachments

(1 file)

This is causing perma-red in Travis.

npm ERR! peerinvalid The package marionette-client does not satisfy its siblings' peerDependencies requirements!
npm ERR! peerinvalid Peer marionette-apps@0.3.4 wants marionette-client@>=1.1.6
npm ERR! peerinvalid Peer marionette-helper@0.1.0 wants marionette-client@>=1.1.0
npm ERR! peerinvalid Peer marionette-js-runner@0.4.0 wants marionette-client@>=1.0.0
The problem is that for marionette-apps, we specify version '~0.3.3', which will actually fetch '0.3.4' based on semvar rules. We need to specify '0.3.3' instead.
Comment on attachment 8412036 [details] [review]
Github PR, use specific version of marionette apps

LGTM. Thanks :mhenretty!
Attachment #8412036 - Flags: review?(gaye) → review+
v1.3t: https://github.com/mozilla-b2g/gaia/commit/5df4d87d740a50e43f4c1fe56a10759e24a0f471
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [systemsfe][p=1]
v1.3 actually had the same issue, so I applied it there too:

v1.3: 12383b1282a960c0cbde1c1c45b0ce0f1cb7cac7

Thanks for applying the fix beforehand, it was easier for me ;)
You need to log in before you can comment on or make changes to this bug.