refreshing a page with a form always pulls from cache

VERIFIED DUPLICATE of bug 46845

Status

()

Core
HTML: Form Submission
VERIFIED DUPLICATE of bug 46845
16 years ago
16 years ago

People

(Reporter: Jon Hall, Assigned: rods (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I hope this isn't a dupe, I looked around and couldn't find it so here goes. I
really hate this bug...It really gets in the way of development.

When refreshing a page with a form on it after you have submitted it to itself,
by either leaving the action parameter or setting the action parameter to the
same page. Mozilla will _always_ pull from the cache. If you change the html,
then hit refresh, you will never see the changes. To reproduce you only have to
have a page with a form, and a button to submit it.

Refreshing on forms should obey the cache settings in preferences/cache.

Comment 1

16 years ago
This sounds like duplicate of 46845, reopen if you disagree

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
Reopening. Simply put. On the preferences menu under cache, it says "Compare 
the page in the cache to the page on the network:" Everytime. 

Mozilla is not checking for differences Everytime as I have selected. Either 
the preferences menu is labeled wrong or it is a bug. So either way it is a bug.

http://bugzilla.mozilla.org/show_bug.cgi?id=46845 seems to be an issue with 
form fields keeping their actual values after a reload. I have not seen that 
behavior. What I am seeing is very similar though it has nothing to do with 
form field values. The entire page is loaded from the cache regardless of cache 
settings.

I really dont have high hopes for this bug though. Mozilla has been taking a 
very anti developer stance lately.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

16 years ago
I tried to reproduce it and followed these steps:
1)Created a file with a form:
<HTML><BODY>
<FORM><INPUT><INPUT type="submit"></FORM></BODY></HTML>

2)Loaded it in the 0.9.4 build from 2001-09-17
3)Eited the file by adding some text after the form "test" for example. 4)Saved it
5)In the browser I clicked the submit button

Results: The browser reloaded the page with the modifications and displayed
"test" after the form...

I tried this on windows 98 and 2000 both from local drive and from a server,
same thing happened. Am I doing something wrong?
(Reporter)

Comment 4

16 years ago
between steps 2 and 3, click submit.

Comment 5

16 years ago
Hmm, I still cannot reproduce it... what is the build you are using? 

Comment 6

16 years ago
I'm marking this a dupe, after the coments that the reporter has sent me.

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.