Closed Bug 1001403 Opened 5 years ago Closed 2 years ago

[Dialer][RIL][V1.3T] Cannot receive an incoming call while you are using 2G data network

Categories

(Firefox OS Graveyard :: RIL, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: whsu, Assigned: bruce.jiang)

Details

(Whiteboard: [POVB][tarako don't support DTM])

Attachments

(1 file)

Attached file RIL_20140425_002
* Description:
  User cannot receive an incomming call while user are using 2G network.
  This bug happens on V1.3T. Cannot reproduce it on Buri with V1.4 build. Might be a POVB issue?
  I would like to highlight this problem because vendor will ship Tarako device which only supports 2G and 2G edge data network.
  Attach the log. (RIL_20140425_002)

* Pre-condition:
  Prepare two mobile devices

* Reproduction steps:
  1. Device-A enables 2G only data network on setting app
     * Note: You can test it via Taiwan Mobile SIM card.
  2. Device-A launches the browser and visits a website
  3. Device-B makes a phone call to Device-A

* Expected result:
  Device-A can receives an incomming call

* Actual result:
  Device-A cannot receives any incomming call

* Reproduction build: V1.3t (Tarako)
  - Gaia      706f474230432c8cb01e124aee2c055ec902aa1d
  - Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/26ef3dded9ff
  - BuildID   20140424014003
  - Version   28.1
blocking-b2g: --- → 1.3T?
It's a limitation of 2G technology. You could not use data(PS) and telephony call(CS) simultaneously. However, modem may have some hack to make it possible.
- Buri uses Qcom's modem.
- Tarako uses SPRD's modem
They could have different capability. Suggest you to compare it with SPRD's android device.
Agree with Aknow.
I
Flags: needinfo?(whsu)
As you mentioned, it seems like SPRD does not implement DTM because Android version(Tarako) also cannot receive incoming call.
http://en.wikipedia.org/wiki/Dual_Transfer_Mode
ni? James on the support of DTM on Tarako
Flags: needinfo?(james.zhang)
Loop Sam.
Flags: needinfo?(james.zhang) → needinfo?(sam.hua)
Hi,
sorry ,what does "DTM“ mean?
Flags: needinfo?(sam.hua) → needinfo?(whsu)
DTM stands for Dual Transfer Mode.

http://en.wikipedia.org/wiki/Dual_Transfer_Mode

Hi Sam:
 Please help check with modem team to see if they can support DTM.
Flags: needinfo?(whsu)
ni? James
Flags: needinfo?(james.zhang)
Whiteboard: [POVB]
Loop Ming.
Assignee: nobody → ming.li
Flags: needinfo?(james.zhang)
Assignee: ming.li → sam.hua
Assignee: sam.hua → bruce.jiang
tarako don't support DTM, it's known issue.
Whiteboard: [POVB] → [POVB][tarako don't support DTM]
blocking-b2g: 1.3T? → ---
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.