Closed Bug 1001523 Opened 6 years ago Closed 6 years ago

New Tab grid does not provide enough padding below the grid

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 31

People

(Reporter: Mardak, Assigned: Mardak)

References

Details

(Keywords: regression, Whiteboard: p=2 s=it-31c-30a-29b.3 [qa!])

Attachments

(3 files)

Attached image screenshot of problem
If I reduce the size of the window just before any rows/cols are reduced, some of the bottom is getting cut off with scrollbars appearing for the page.

For a unit test, I'm not sure if we just resize the window height and make sure there's never a scrollbar?
Assignee: nobody → edilee
Status: NEW → ASSIGNED
Flags: firefox-backlog+
Whiteboard: p=2 s=it-31c-30a-29b.3
Seems like part of the problem is the margin is set on the newtab-margin-undo-container, so .offsetHeight does not include it. Moving the margin into a child node, i.e., newtab-undo-container, does have it included in the calculation.

adw, also, why is the top margin flex 1 and bottom margin flex 2?
Attached patch v1Splinter Review
Moves margin/padding so the parent container we calculate offsetHeight from has the correct height. This applies both to undo and search containers (calculate height from margin-undo-container with margin on undo-container and from search-container with margin on search-form).
Attachment #8412800 - Flags: review?(adw)
Comment on attachment 8412800 [details] [diff] [review]
v1

Review of attachment 8412800 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8412800 - Flags: review?(adw) → review+
Whiteboard: p=2 s=it-31c-30a-29b.3 → p=2 s=it-31c-30a-29b.3 [qa+]
Hi Liz, who should the QA contact be for this bug?
Flags: needinfo?(lhenry)
https://hg.mozilla.org/mozilla-central/rev/09d2cda1bb73
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
QA Contact: cornel.ionce
Verified this fix on latest Nightly, build ID: 20140428030203.
Tested on Mac OS X 10.9, Ubuntu 13.04, Windows 7 64 bit and on a Microsoft Surface Pro 2 running Windows 8.1 64bit.

User Agents:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:31.0) Gecko/20100101 Firefox/31.0
Mozilla/5.0 (X11; Linux i686; rv:31.0) Gecko/20100101 Firefox/31.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
Status: RESOLVED → VERIFIED
Flags: needinfo?(lhenry)
Whiteboard: p=2 s=it-31c-30a-29b.3 [qa+] → p=2 s=it-31c-30a-29b.3 [qa!]
(In reply to Ed Lee :Mardak from comment #0)
> Created attachment 8412731 [details]
> screenshot of problem
> 
> If I reduce the size of the window just before any rows/cols are reduced,
> some of the bottom is getting cut off with scrollbars appearing for the page.
> 
> For a unit test, I'm not sure if we just resize the window height and make
> sure there's never a scrollbar?

So...did this make it into Fx31 release? I'm not noticing a change. However, it was in the beta. What happened?
(In reply to PimpUigi from comment #8)
> So...did this make it into Fx31 release? I'm not noticing a change. However,
> it was in the beta. What happened?
If "this" is referring to this bug, it does not exist in 31Release because the fixed size tiles + reduced rows/cols were backed out before release. If "this" refers to the fix, then it is still partially in 31 as it moved the margin to a more appropriate container. See Bug 1038997
Ah. I see. Thank you.
Which version of Firefox are those things aimed at now?
You need to log in before you can comment on or make changes to this bug.