Closed Bug 1001529 Opened 6 years ago Closed 6 years ago

Telemetry experiments: "Experiments" container not initially visible when there's a disabled experiment

Categories

(Toolkit :: Add-ons Manager, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1001787

People

(Reporter: kjozwiak, Unassigned)

References

Details

When removing the experiment from the "Experiments" add-on manager using the visible "Remove" button, the experiment will be removed from the container. Refreshing the screen at that point will completely remove the "Experiments" add-ons container. The "Experiments" category will appear again once you hit the refresh button the second time around.

However, if you right click on the experiment and select "Remove", refreshing the first time around will correctly disable the experiment that was removed and the "Experiments" container will still be visible.

Video of issue:
- http://youtu.be/jUxEGVY7YMw

Steps to reproduce the issue:

1) Install the latest Nightly Firefox
2) Once installed, setup a local staging server (see Bug # 973998 on instructions)
3) Once the experiment is enabled and the "Experiments" category is visible, select "Remove" (experiment will disappear)
4) Hit the refresh button and you'll notice that the entire "Experiments" category is removed
5) Hit refresh the second time and you'll notice that the "Experiments" category will re-appear and the experiment will be disabled

Current Behaviour:

- Removing the experiment via the visible "Remove" button should have the same behaviour when removing the experiment via the right click method.

Expected Behaviour:

- The "Experiments" category shouldn't be removed and should be correctly "refreshed" the first time around rather than pressing refresh two different times. Behaviour should be consistent when using any of the three "remove" methods.
I think this is an expected manifestation of bug 992258 not being landed yet.
No longer blocks: 973992
Depends on: 992258
Blocks: telex
While going through Bug # 1001787, I noticed that when you disable an experiment and re-load Firefox, the experiment container in the add-on manager completely disappears. Reloading the add-on manager or refreshing it won't do anything. However if you go into "about:support" and then re-load the add-on manager, the container will appear and will correctly list the disabled experiment.

Probably a cause of Bug # 992258 as Benjamin mentioned in comment #1
Fixed by bug 1001787.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1001787
Georg,

It looks like this hasn't been fixed in Bug # 1001787 as I can still reproduce this problem. Once you disable/uninstall an experiment and close/re-open firefox, the "Experiments' container will won't be visible unless you visit about:support. At that point, you can refresh about:addons and the "Experiments" container will re-appear.

We should be displaying the "Experiments" container under about:addons the first time around if:
- There's an experiment currently installed
- There's previously installed experiments that have been disabled/removed

Originally, you could press refresh a few times and the "Experiments" will appear without visiting about:support.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: "Remove" experiment removes the add-on container, refreshing twice will displays it again → Telemetry experiments: "Experiments" container not initially visible when there's a disabled experiment
Quick Clarification:

Originally, you could just refresh about:addons and the "Experiments" container will appear. Now, you have to visit about:support before you can refresh about:addons to get the "Experiments" container. Without visiting about:support, refreshing about:addons won't show the "Experiments" container.
(In reply to Kamil Jozwiak [:kjozwiak] from comment #5)
> Originally, you could just refresh about:addons and the "Experiments"
> container will appear. Now, you have to visit about:support before you can
> refresh about:addons to get the "Experiments" container. Without visiting
> about:support, refreshing about:addons won't show the "Experiments"
> container.

In bug 993084 we actually started to delay initializing the experiments manager for performance reasons by 30 seconds after session init - i think this is what you're actually seeing and visiting about:support bypasses that.

Please try again and wait a little more than 30 seconds after second start to re-check this.
Flags: needinfo?(kamiljoz)
How do we make it so that opening the addon manager will load experiments?
Waiting the 30 seconds definitely worked, however I did notice the "Experiments" container quickly "flash" as it appeared/disappeared if about:addons was opened before the 30 seconds delay. I think we should clean that up so users don't see things appearing and disappearing quickly.
Flags: needinfo?(kamiljoz)
(In reply to Kamil Jozwiak [:kjozwiak] from comment #8)
> Waiting the 30 seconds definitely worked, however I did notice the
> "Experiments" container quickly "flash" as it appeared/disappeared if
> about:addons was opened before the 30 seconds delay. I think we should clean
> that up so users don't see things appearing and disappearing quickly.

Sure, although that doesn't seem quite as pressing. Can you file a new bug on this?
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1001787
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #7)
> How do we make it so that opening the addon manager will load experiments?

Filed bug 1005270.
You need to log in before you can comment on or make changes to this bug.