Closed Bug 1001541 Opened 6 years ago Closed 2 years ago

[B2G][Tarako][Email]Intermittent layer of black briefly displays after user taps and input text within a field and selects the manual setup link

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v1.3 affected, b2g-v1.3T affected)

RESOLVED WONTFIX
Tracking Status
b2g-v1.3 --- affected
b2g-v1.3T --- affected

People

(Reporter: mclemmons, Unassigned)

References

()

Details

(Keywords: perf, Whiteboard: [c=progress p= s= u=tarako] [tarako-exploratory])

Attachments

(2 files)

Attached file firewatch log
User taps Email app and inserts text within any or all of the entry fields (Your name, email address, password) but rather than selecting done, taps the manual setup link instead. Periodically, the pop up keyboard is replaced with a temporary black square before transitioning to the manual setup page. This is realistic as user may have attempt to start auto setup, changes their mind, and immediately taps the manual setup link to start that process.

Repro Steps:
1) Updated Tarako to BuildID: 20140424014003 
2) Tap Email App 
3) Input text in any or all of the text available fields (name, address, password)
4) Tap manual setup link 

Actual:
The pop up keyboard is replaced with a temporary black square before transitioning to the manual setup page. Occasionally when backing out of the manual setup page, the black square re-emerges, but less often than entrance into the Manual Setup page.

Expected:
Graceful transition between screens without a black square appearing

Notes: 
Repro frequency: 17/20 – 85 percent for entrance in manual setup page 5/20 – 25 percent for exit manual setup screen.

See attached: Logcat, Firewatch, Video clip = https://www.youtube.com/watch?v=wCXr2EFd4YA

Environmental Variables: 
Device: Tarako 1.3T MOZ 
BuildID: 20140424014003 
Gaia: 706f474230432c8cb01e124aee2c055ec902aa1d 
Gecko: 26ef3dded9ff 
Version: 28.1
Firmware Version: sp6821a_gonk4.0_user.pac
This issue does reproduce on 1.3 Buri. Device demonstrates black square presentation after following STR from Comment 0 intermittently. Same intermittent behavior entering (85 percent) and exiting manual setup (20 percent).

Environmental Variables: 
Device: Buri 1.3 MOZ 
BuildID: 20140424024004 
Gaia: 32a9e3db738e0b3bc44a4d4d5c16512a2617a2cf 
Gecko: 97ca2fdf3cf4 
Version: 28.0
Firmware Version: v1.2-device.cfg
Attached file Logcat Email
The keyboard appearing/disappearing results in the email app's window being resized.  This is primarily a platform/keyboard issue.  Having said that, the email app can do a fair bit of mitigation by controlling when focus/blur events occur and for allowing time for the keyboard to disappear/appear.

This is not a candidate for being fixed on v1.3T.
I agree with asuth; Moving to keyboard and flagging as a perf bug.
Component: Gaia::E-Mail → Gaia::Keyboard
Keywords: perf
Douglas, this sounds exactly like what you were describing in our meeting today regarding app window resizing when the keyboard appears and disappears. Is your work applicable?
Flags: needinfo?(drs+bugzilla)
Priority: -- → P2
Whiteboard: [tarako-exploratory] → [tarako-exploratory][c=progress p= s= u=]
(In reply to Jon Hylands [:jhylands] from comment #5)
> Douglas, this sounds exactly like what you were describing in our meeting
> today regarding app window resizing when the keyboard appears and
> disappears. Is your work applicable?

Yes, my work should speed this up but not entirely mitigate it, though it's not something we'll be able to uplift to 1.3T I don't think.
Flags: needinfo?(drs+bugzilla)
Whiteboard: [tarako-exploratory][c=progress p= s= u=] → [c=progress p= s= u=tarako] [tarako-exploratory]
Closing all intermittent test failures for Firefox OS (since we're not focusing on it anymore).

Please reopen if my search included your bug by mistake.
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.