Gaia integration tests for NFC vcard sharing

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
5 years ago
Last year

People

(Reporter: kamituel, Assigned: kamituel)

Tracking

unspecified
x86
macOS
Dependency tree / graph

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

We should have integration tests for a basic scenario where user receives vcard via NFC (i.e. contacts app should open and prompt user whether new contact should be added).

Once NFC support in emulator lands, would it be possible to have such test cases?

(note: this is a twin bug of https://bugzilla.mozilla.org/show_bug.cgi?id=1001540, both cover similar test cases)
Flags: needinfo?(alive)
I'd answered.
Flags: needinfo?(alive)
Depends on: 980851
This bug blocks NFC 2.0 release.
Blocks: b2g-NFC-2.0
blocking-b2g: --- → backlog
Assignee: nobody → kamituel
Since we cannot really run emulator command in Python integration test case (Gaia UI tests), we're blocked by 997244.
Depends on: 997244
blocking-b2g: backlog → ---
Firefox OS is not being worked on
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.