Closed Bug 1001586 Opened 6 years ago Closed 4 years ago

[B2G][Component][Tarako] When trying to access the Mozilla Public License the user experiences an OOM crash

Categories

(Firefox OS Graveyard :: Performance, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(tracking-b2g:-, b2g-v1.3 unaffected, b2g-v1.3T affected)

RESOLVED WONTFIX
tracking-b2g -
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- affected

People

(Reporter: dharris, Unassigned)

References

()

Details

(Keywords: memory-footprint, perf, Whiteboard: [c=memory p= s= u=tarako] [MemShrink:P3] [tarako-exploratory])

Attachments

(1 file)

Attached file Logcat, Firewatch
Description:
The Mozilla Public License causes an out of memory crash when accessed from the marketplace sign in page

Repro Steps:
1) Update a Tarako to BuildID: 20140424014003
2) Open the marketplace app
3) Go to Settings> Sign in
4) Tap on the Persona's 'Terms' link
5) Scroll Down and tap on the 'Mozilla Public License' link

Actual:
An OOM crash occurs and the marketplace turns blank white, or closes out entirely

Expected:
The user is taken to the appropriate page without issue

1.3t Environmental Variables:
Device: Tarako 1.3t
BuildID: 20140424014003
Gaia: 706f474230432c8cb01e124aee2c055ec902aa1d
Gecko: 26ef3dded9ff
Version: 28.1
Firmware Version: sp6821

Keywords: Out of Memory, Proprietary Rights

Notes: When typing the link in on my computer, the link does work.

Repro frequency: 100%
See attached: Logcat, Firewatch, Video - https://www.youtube.com/watch?edit=vd&v=LZ7LZA_6QMw
The above issue does not occur on Buri 1.3


1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140423024002
Gaia: fb2b8e25e8095a5db49b5eb68c74b49f180605d4
Gecko: da2500909f91
Version: 28.0
Firmware Version: v1.2-device.cfg
Marketplace app is going to change... 
It's not going to have the Persona sign in.

Having said that until it's changed I'll leave this open.
Can this be reproduced by going to http://www.mozilla.org/MPL/ in the browser?
Component: Gaia::Browser → General
Keywords: qawanted
When going to http://www.mozilla.org/MPL/ in the browser app I was able to to view the page without any issue.
QA Contact: dharris
I'm going to file a separate bug for figuring out what we should do with persona for Tarako, since we're seeing a few problems with it in Tarako.
Component: General → Performance
Keywords: footprint, perf
Whiteboard: [tarako-exploratory] → [tarako-exploratory][MemShrink]
(In reply to Jason Smith [:jsmith] from comment #5)
> I'm going to file a separate bug for figuring out what we should do with
> persona for Tarako, since we're seeing a few problems with it in Tarako.

Actually, let me check what happens on 123done.org before I file a bug.
Whiteboard: [tarako-exploratory][MemShrink] → [tarako-exploratory][MemShrink:P3]
Priority: -- → P3
Whiteboard: [tarako-exploratory][MemShrink:P3] → [c=memory p= s= u=tarako] [MemShrink:P3] [tarako-exploratory]
Status: NEW → RESOLVED
Closed: 4 years ago
tracking-b2g: --- → -
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.