[B2G][Tarako]Unexpected sound heard during device boot up after restart or power off and turning phone on

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: mclemmons, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(b2g-v1.3 affected, b2g-v1.3T affected)

Details

(Whiteboard: [tarako-exploratory], )

Attachments

(2 attachments)

Posted file firewatch log
User powers off device and long taps the start button. While the Firefox OS and Firefox logo appears (roughly the 25-26 second mark of attached video), there is a brief tone heard prior to the screen soon transitioning to the homescreen. This is suspicious because the tone is not heard during the same process of 1.3 Buri. Furthermore, if this is a device expectation, user would believe this occurring at the SpreadTrum page and not during the Firefox screens - as this is the only difference in terms of screens between the Buri and Tarako.

Repro Steps:
1) Updated Tarako to BuildID: 20140424014003 
2) Power off or Restart from long press power button
3) Long press power button and observe phone behavior

Actual:
Spreadtrum page appears. Firefox “fox image” appears. Firefox logo and text appears with an audible tone then homescreen appears.

Expected:
Spreadtrum page appears. Firefox “fox image” appears. Firefox logo and text appears without an audible tone then homescreen appears. Or Spreadtrum page appears with audible tone. Firefox “fox image” appears. Firefox logo and text appears without an audible tone then homescreen appears.

Notes: 
Repro frequency: 10/10 – 100 percent 

See attached: Logcat, Firewatch, Video clip = https://www.youtube.com/watch?v=SJxnBv9pElE&feature=youtu.be

Environmental Variables: 
Device: Tarako 1.3T MOZ 
BuildID: 20140424014003 
Gaia: 706f474230432c8cb01e124aee2c055ec902aa1d 
Gecko: 26ef3dded9ff 
Version: 28.1
Firmware Version: sp6821a_gonk4.0_user.pac
This issue does not reproduce on 1.3 Buri. Device does not demonstrate an audible tone during the device start up process, following the STR from Comment 0.

Environmental Variables: 
Device: Buri 1.3 MOZ 
BuildID: 20140424024004 
Gaia: 32a9e3db738e0b3bc44a4d4d5c16512a2617a2cf 
Gecko: 97ca2fdf3cf4 
Version: 28.0
Firmware Version: v1.2-device.cfg
Correction to Comment 1, upon further review, user able to hear similar tone during boot up on Buri 1.3 during the Firefox OS stage. Uncertain if this is intended at this precise point.
I believe this is no longer happening on current phones
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.