Closed Bug 1001686 Opened 6 years ago Closed 2 years ago

Add more informative messaging when a Legacy Sync user opens about:accounts page (currently it's blank)

Categories

(Firefox :: Sync, defect)

29 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: guigs, Unassigned)

Details

(Whiteboard: [qa+])

Attachments

(2 files)

Description: https://support.mozilla.org/en-US/questions/996489
navigate to about:accounts and see a blank page

Windows 8.1 vs 29-31
Mac vs 31
different networks and computers it is reproducible. 


Troubleshooting steps taken: 
- works after visiting the page 3 times 
- does not work with blocking http network settings
can you install httpfox add-on and click start, then attempt to load about:accounts

what response code are you getting? Please paste anything you see for https://accounts.firefox.com

Also, can you try loading this? https://accounts.firefox.com it's
Apparently one issue is the Sync account signon is not supporting those without en-US enabled.

My Mozilla Fx29 en-GB did not work with the new sync until en-US added. My Mozilla Fx31 worked but did already have en-US. 

I still have not resolved the issue with the Canonical Fx30. The work around of adding en-US does not yet help with that, however not yet tested in a clean profile with en-US. I have posted further details e.g. response headers in github & support threads.
Fx30 issue was apparently a profile or plugin issue. Not bothered yet to identify what. Possibly use of NoScript interfering with this. With plugins disabled, in safe mode and en-US available new Sync signs in ok. With luck github people are working on a fix for the language part of the issue. 

Meanwhile as a workaround add en-US 
about:preferences -> |Content| -> Languages -> [Choose] -> [Select ...]  
Select "English/United States [en-us]", click "Add"
Now click on the Sync button or use about:accounts as normal to sign in or register.
( From https://github.com/mozilla/fxa-content-server/issues/1017#issuecomment-41598423 )
I am having this same problem. I installed httpfox and it didn't resolve the issue.
I've disabled all add-ons and about:accounts is still blank.
I also tried to restart in safe mode and no luck. I am running the en-US Fx 29.0 release channel Firefox. Should the "reset firefox" button?
Whiteboard: [qa+]
this should be fixed as of 4/28 at 6pm PT
https://github.com/mozilla/fxa-content-server/issues/1017

investigating.
another item to try is change your cookie policy. There were reports of this happening with Fx31 and I'm not sure if it's fixed everywhere. Go here:
1. preferences > privacy > History - set to custom
2. change Accept third party cookies to 'always'
* If it's on 'never' this may prevent the page to display.
:cmore, a little more debugging detail would help us diagnose your issue, e.g., https://github.com/mozilla/fxa-content-server/issues/1017#issuecomment-41626018

* some output from the browser console 
* a list of remote requests made when loading about:accounts
* whether this can replicated in a fresh profile
Flags: needinfo?(chrismore.bugzilla)
(In reply to Edwin Wong [:edwong] from comment #9)
> another item to try is change your cookie policy. There were reports of this
> happening with Fx31 and I'm not sure if it's fixed everywhere. Go here:
> 1. preferences > privacy > History - set to custom
> 2. change Accept third party cookies to 'always'
> * If it's on 'never' this may prevent the page to display.

It was already set to "always".
Flags: needinfo?(chrismore.bugzilla)
(In reply to Chris Karlof [:ckarlof] from comment #10)
> :cmore, a little more debugging detail would help us diagnose your issue,
> e.g.,
> https://github.com/mozilla/fxa-content-server/issues/1017#issuecomment-
> 41626018
> 
> * some output from the browser console 
> * a list of remote requests made when loading about:accounts
> * whether this can replicated in a fresh profile

* nothing shows up in the network monitor when refreshing about:accounts.
* html source of my about:accounts: http://pastebin.mozilla.org/5011555
* I haven't tried a fresh profile or a "reset firefox"..yet (will try that next)
* See attached screenshot.
Let me know if there is anything else you want me to do before trying the reset Firefox.
:cmore, are you currently or previously connected to old Sync in this profile?
Flags: needinfo?(chrismore.bugzilla)
:cmore, if enable old sync and open about:accounts, I see a DOM layout similar to what you're seeing. If you have old sync enabled, this behavior is expected. There is no UI control to navigate old sync users to about:accounts, but we could probably provide some better messaging here. If you want to use FxA Sync, you need to first disconnect from old Sync via the Sync Preferences pane.

If you're not using old sync (or have previously and disconnected it), please let us know because that would be a bug.
(In reply to Chris Karlof [:ckarlof] from comment #16)
> :cmore, are you currently or previously connected to old Sync in this
> profile?

Yes, I am connected to an old sync profile currently. I thought this could be expected behavior, but I could not confirm it. Shall I try to disconnect the old sync, sign up for Firefox Accounts, and verify I see all of the UI?
Flags: needinfo?(chrismore.bugzilla)
> Shall I try to disconnect the old sync, sign up for Firefox Accounts, and verify I see all of the UI?

Sure.

A word of warning: if you disconnect from old sync, and want to re-connect to old sync, you will need to do so from Fx 28 or older. I.e., new device connections to old sync is not supported in Fx29+.
(In reply to Chris Karlof [:ckarlof] from comment #20)
> > Shall I try to disconnect the old sync, sign up for Firefox Accounts, and verify I see all of the UI?
> 
> Sure.
> 
> A word of warning: if you disconnect from old sync, and want to re-connect
> to old sync, you will need to do so from Fx 28 or older. I.e., new device
> connections to old sync is not supported in Fx29+.

Makes sense and thanks for the warning. I don't want to be a laggard and be on the "old sync". :)
:cmore, I'm marking this as resolved. Please update to verified when you verify disconnecting from old sync works for you.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
(In reply to Chris Karlof [:ckarlof] from comment #22)
> :cmore, I'm marking this as resolved. Please update to verified when you
> verify disconnecting from old sync works for you.

As soon as I disconnect old sync, about:accounts is not blank. We really should have conditional content on the page that tells the user what is going on when using the old sync.
Summary: Sync about:accounts page is blank → about:accounts page is blank when user has Legacy Sync enabled
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
I'll re-open and rename this bug to track having some more informative messaging when the user visits about:accounts with Legacy Sync enabled.
Summary: about:accounts page is blank when user has Legacy Sync enabled → Add more informative messaging when a Legacy Sync user opens about:accounts page (currently it's blank)
Since we have no exposed way to get to about:accounts in this scenario, I'm not too worried about this bug in the near term.

In the medium term, we're going to implement something to move old-sync users to new-sync, and that will likely involve giving them an about:accounts page that lets them easily migrate, which would also fix this.
We've now killed legacy sync support.
Status: REOPENED → RESOLVED
Closed: 6 years ago2 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.