Closed Bug 1002467 Opened 8 years ago Closed 8 years ago

Debugging xpcshell tests is broken

Categories

(Testing :: XPCShell Harness, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 952211

People

(Reporter: ehsan.akhgari, Unassigned)

References

Details

Here is what I get:

$ ./mach xpcshell-test --debugger lldb --debugger-interactive toolkit/mozapps/update/tests/unit_aus_update/urlConstruction.js
From _tests: Kept 17486 existing; Added/updated 0; Removed 0 files and 0 directories.
 0:02.15 INFO | Running tests sequentially.
Current executable set to '/Users/ehsan/moz/src/obj-ff-dbg.noindex/dist/bin/xpcshell' (x86_64).
(lldb) r
/bin/sh: -c: line 0: syntax error near unexpected token `('
/bin/sh: -c: line 0: `exec /usr/bin/arch -arch x86_64 /Users/ehsan/moz/src/obj-ff-dbg.noindex/dist/bin/xpcshell -g /Users/ehsan/moz/src/obj-ff-dbg.noindex/dist/bin -a /Users/ehsan/moz/src/obj-ff-dbg.noindex/dist/bin -r /Users/ehsan/moz/src/obj-ff-dbg.noindex/dist/bin/components/httpd.manifest -m -s -e const\ _HTTPD_JS_PATH\ =\ /Users/ehsan/moz/src/obj-ff-dbg.noindex/dist/bin/components/httpd.js; -e const\ _HEAD_JS_PATH\ =\ /Users/ehsan/moz/src/testing/xpcshell/head.js; -e const\ _TESTING_MODULES_DIR\ =\ /Users/ehsan/moz/src/obj-ff-dbg.noindex/_tests/modules/; -f /Users/ehsan/moz/src/testing/xpcshell/head.js -p /var/folders/ry/m4kkhrl17c76cqyfd5qv5sph0000gn/T/tmpDTSDYj -e const\ _SERVER_ADDR\ =\ localhost -e const\ _HEAD_FILES\ =\ [/Users/ehsan/moz/src/obj-ff-dbg.noindex/_tests/xpcshell/toolkit/mozapps/update/tests/unit_aus_update/head_update.js]; -e const\ _TAIL_FILES\ =\ []; -e const\ _TEST_FILE\ =\ [/Users/ehsan/moz/src/obj-ff-dbg.noindex/_tests/xpcshell/toolkit/mozapps/update/tests/unit_aus_update/urlConstruction.js]; -e _execute_test();\ quit(0);'
error: initial process state wasn't stopped: exited
(lldb)

It seems like it's not longer possible to debug these tests. :(  I was hoping to be able to debug a test here for bug 994964.
Is this the same problem as bug 952211?
Flags: needinfo?(ehsan)
(In reply to Nathan Froyd (:froydnj) from comment #1)
> Is this the same problem as bug 952211?

Hard to say.  I don't have gdb to test the difference.  :/  But on the surface it looks similar enough, so, let's dupe.
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(ehsan)
Resolution: --- → DUPLICATE
Duplicate of bug: 952211
You need to log in before you can comment on or make changes to this bug.