Closed Bug 1002613 Opened 7 years ago Closed 7 years ago

"expected to find ssltunnel" error when running mochitests on B2G emulator

Categories

(Testing :: Mochitest, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1002545

People

(Reporter: botond, Unassigned)

Details

STR:
  1. Build the B2G emulator based on the master branch. I built in debug mode, not sure if it's relevant.
  2. Run "./mach mochitest-remote"

Expected results:
  Mochitests run.

Actual results:
  See output below.

botond@botond-Precision-T1650:~/dev/mozilla/b2g-emulator > ./mach mochitest-remote
From _tests: Kept 11594 existing; Added/updated 0; Removed 0 files and 0 directories.
waiting for system-message-listener-ready...
...done
MochitestServer : launching [u'/home/botond/dev/mozilla/b2g-emulator/gaia/xulrunner-sdk-30/xulrunner-sdk/bin/xpcshell', '-g', u'/home/botond/dev/mozilla/b2g-emulator/gaia/xulrunner-sdk-30/xulrunner-sdk/bin', '-v', '170', '-f', u'/home/botond/dev/mozilla/out-of-tree-objdirs/gonk-emulator/_tests/testing/mochitest/httpd.js', '-e', "const _PROFILE_PATH = '/tmp/tmpm1XFYD'; const _SERVER_PORT = '8888'; const _SERVER_ADDR = '10.242.24.73'; const _TEST_PREFIX = undefined; const _DISPLAY_RESULTS = false;", '-f', '/home/botond/dev/mozilla/out-of-tree-objdirs/gonk-emulator/_tests/testing/mochitest/server.js']
runtests.py | Server pid: 11801
runtests.py | Websocket server pid: 11803
INFO | runtests.py | expected to find ssltunnel at /home/botond/dev/mozilla/b2g-emulator/gaia/xulrunner-sdk-30/xulrunner-sdk/bin/ssltunnel
Automation Error: Exception caught while running tests
Traceback (most recent call last):
  File "/home/botond/dev/mozilla/out-of-tree-objdirs/gonk-emulator/_tests/testing/mochitest/runtestsb2g.py", line 332, in run_remote_mochitests
    retVal = mochitest.run_tests(options)
  File "/home/botond/dev/mozilla/out-of-tree-objdirs/gonk-emulator/_tests/testing/mochitest/runtestsb2g.py", line 117, in run_tests
    self.startServers(options, None)
  File "/home/botond/dev/mozilla/out-of-tree-objdirs/gonk-emulator/_tests/testing/mochitest/runtestsb2g.py", line 209, in startServers
    MochitestUtilsMixin.startServers(self, options, debuggerInfo)
  File "/home/botond/dev/mozilla/out-of-tree-objdirs/gonk-emulator/_tests/testing/mochitest/runtests.py", line 555, in startServers
    self.sslTunnel.start()
  File "/home/botond/dev/mozilla/out-of-tree-objdirs/gonk-emulator/_tests/testing/mochitest/runtests.py", line 742, in start
    exit(1)
  File "/usr/lib/python2.7/site.py", line 375, in __call__
    raise SystemExit(code)
SystemExit: 1
Stopping web server
Stopping web socket server
Stopping ssltunnel

After talking to :jmaher and :ctalbert I worked around the problem by downloading a test zip from ftp://ftp.mozilla.org/pub/firefox/nightly/latest-trunk/ and copying everything from the 'bin' directory into /home/botond/dev/mozilla/b2g-emulator/gaia/xulrunner-sdk-30/xulrunner-sdk/bin/.
Ni?ing :ahal as per IRC conversation with :jmaher.
Flags: needinfo?(ahalberstadt)
(In reply to Botond Ballo [:botond] from comment #0)
> After talking to :jmaher and :ctalbert I worked around the problem by
> downloading a test zip from
> ftp://ftp.mozilla.org/pub/firefox/nightly/latest-trunk/ and copying
> everything from the 'bin' directory into
> /home/botond/dev/mozilla/b2g-emulator/gaia/xulrunner-sdk-30/xulrunner-sdk/
> bin/.

Update: Copying everything from the 'bin' directory caused problems with version mismatches between xpcshell and libxul.so. Copying _only_ the ssltunnel binary worked fine.
The correct fix here is to have the emulator builds also compile xpcshell.  I've been looking into it, but this requires more work.  See bug 1002545 for a workaround.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1002545
Flags: needinfo?(ahalberstadt)
You need to log in before you can comment on or make changes to this bug.