0.9.4 linux installer crashes with Custom option

VERIFIED DUPLICATE of bug 97249

Status

SeaMonkey
Installer
--
critical
VERIFIED DUPLICATE of bug 97249
17 years ago
14 years ago

People

(Reporter: Scott McPeak, Assigned: Syd Logan)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
The 0.9.4 installer for Linux crashes when custom components are selected:

  - download mozilla-i686-pc-linux-gnu-0.9.4-installer.tar.gz
  - unpack it; cd into mozilla-installer
  - run ./mozilla-installer
  - "next" at readme
  - "accept" at license statement
  - choose "custom" components
  - pick alternate destination directory: "/tmp/mozilla-0.9.4"
  - "next", "yes" to confirmation
  - pick only Navigator and Quality Feedback Agent (i.e. deselect others)
  - "next"
  - "install"

At this point installer chugs away, apparently downloading all the necessary
files.  During this process many warnings are seen in the controlling tty:

Gtk-CRITICAL **: file gtkprogress.c: line 518 (gtk_progress_set_percentage):
assertion `percentage >= 0 && percentage <= 1.0' failed.
but these appear harmless.  Finally, the gui dialog closes and it segfaults:

./mozilla-installer: line 55:  7965 Segmentation fault    ./mozilla-installer-
bin --sync $@

(the above text was typed by hand, because 0.9.3's copy+paste isn't working
right, so it might have small typographical errors)
After this failure I blew away the xpi/ directory and tried again, this time
choosing Navigator Only instead of Custom, and the installer worked.  So I
think it has to do with the Custom option.

My system stats:
  Linux on x86
  glibc 2.1.2
  gtk 1.2.8
  kernel 2.2.19

At the time I was running 0.9.3 in another process, I doubt that matters though.

Updated

17 years ago
QA Contact: bugzilla → ktrina

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 89925 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
I don't understand why this is considered a duplicate of 89925.  89925
talks about an assertion failure (which I do not see, even when using the
repro procedure in that bug report, in 0.9.4).  This report documents a
segfault, and it occurs under different circumstances.

Comment 3

17 years ago
I am seeing this with this setup type (Nav/talkback)- adding crash keyword

I do not see with typical or complete setup  types- during those installs, you
get the gtk errors but the install completes. (bug 83478)

no install log
Status: RESOLVED → UNCONFIRMED
Keywords: crash
Resolution: DUPLICATE → ---
Confirmed/reproduced by Grace. nominating because this is a supposedly supported
configuration in the commercial installer as well.

Grace, could you check windows too? Could easily be someone added an XP dependency.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: nsbranch

Comment 5

17 years ago
this is not crashing on WinNT- 

Comment 6

17 years ago
crashing today  - N6 branch- Navigator only

Comment 7

17 years ago
branch build 2001092404

Comment 8

17 years ago
Syd, is this something that you think is serious enough to fix for eMojo?  From
the comments it seems like it is.  If you (or someone on your team) can fix this
in the next day or so, please mark it nsbranch+ if it's a major crasher.  If
not, please mark as nsbranch-.
(Assignee)

Comment 9

17 years ago

*** This bug has been marked as a duplicate of 97249 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 10

17 years ago
Verified as a duplicate of 97249

Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.