PNG images should use native decoder, now uses quicktime plugin

VERIFIED DUPLICATE of bug 69719

Status

()

Core
Plug-ins
--
minor
VERIFIED DUPLICATE of bug 69719
17 years ago
17 years ago

People

(Reporter: Oscar van Vliet, Assigned: av (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001091303

After copying the quicktime plugin DLLs as described in the smoketests, I found
that loading http://www.libpng.org/pub/png/img_png/pngs-img-netpos.png calls the
Quicktime plugin (shows the blue Q logo while loading the image and all).

I was under the impression that Mozilla provided native PNG decoding. If so,
there is no need to use a plugin. It sucks down performance and increases memory
use.

Reproducible: Always
Steps to Reproduce:
1. Install the quicktime plugin
2. Load the URL above
3. Sit and watch


Actual Results:  I saw the Quicktime 5 plugin activate. Status bar says:
'Starting Plugin for type image/png'

Expected Results:  Native mozilla (imagelib) decodes and shows the picture

Quicktime 5 is set to take PNG images in my WinNT setup. I use an NT4SP6,
Celeron 300, 64Mb, S3 Virge DX machine.

Apparently, not all PNG images have this problem. Using the default page for
viewing PNG, Quicktime is apparently not called. Not knowing Imagelib
intimately, this could either be because PNG is not fully supported or because
the mime type handler misdirects. Marked as minor since no loss of functionality
occurs. Nominating for perf keyword.
The quicktime plugin is telling the browser to use it for displaying PNGs.  You
need to turn off the setting if your version is new enough.  See bug 69719 for
more info.

*** This bug has been marked as a duplicate of 69719 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.