Closed Bug 1002802 Opened 6 years ago Closed 6 years ago

[Calendar] visual divider of all day events vs hourly events

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(feature-b2g:2.0, tracking-b2g:backlog)

VERIFIED DUPLICATE of bug 951075
2.0 S2 (23may)
feature-b2g 2.0
tracking-b2g backlog

People

(Reporter: tchung, Unassigned)

References

Details

When the all-day calendar fills up most of the screen, it leaves no evident divider between the allday mode and the hourly mode.   It would great if we can distinguish a divider to the user, so they know they can scroll the bottom.  Right now the UX is merged entirely into one visual.

See screencast: http://youtu.be/bR077_MtcjA


REpro:
1) install 1.4 nightly on any device
2) Have a calendar with a lot of All-day Activities, that it fills up nearly the whole screen
3) at the very bottom, scroll up and down
4) Verify there's a small space that i can scroll my hourly calendar.  however, the UX is intuitive and no visible way to distinguish there's a way to do that.

Expected:
- a visual way to distinguish the hourly view vs all day view to scroll

ActuaL:
- all-day and hourly events all just blend together.  Can tell its scrollable.
Flags: needinfo?(ux-review)
The visual divider will be fixed by visual refresh, however, I have concerns for displaying all the all-day activities. I think we should add a maximum number for displaying all-day activities, and if exceed the max number, the all-day activities will become scrollable, much like what we do in week view. (I prefer max number=2)
Flags: needinfo?(ux-review)
Blocks: 950209
blocking-b2g: 2.0? → backlog
Whiteboard: [priority]
I tried to implement Harly suggestion today but it did not work as expected. Trying to set a max-height for the all-day container breaks the scroll of the hours events.. One suggestion would be to display only 1 event (and make it scroll if more events) or do the same thing we do when multiple events "overlaps", and show the events side-by-side.
feature-b2g: --- → 2.0
(In reply to Harly Hsu from comment #1)
> The visual divider will be fixed by visual refresh, however, I have concerns
> for displaying all the all-day activities. I think we should add a maximum
> number for displaying all-day activities, and if exceed the max number, the
> all-day activities will become scrollable, much like what we do in week
> view. (I prefer max number=2)

can someone point me to what the UX is going to look like with the Visual refresh on this?
(In reply to Tony Chung [:tchung] from comment #3)
> (In reply to Harly Hsu from comment #1)
> > The visual divider will be fixed by visual refresh, however, I have concerns
> > for displaying all the all-day activities. I think we should add a maximum
> > number for displaying all-day activities, and if exceed the max number, the
> > all-day activities will become scrollable, much like what we do in week
> > view. (I prefer max number=2)
> 
> can someone point me to what the UX is going to look like with the Visual
> refresh on this?

You can see the day view visual refresh on bug 951075.
Harly and Tony, are you guys happy with current behavior? (on master) Can we close this bug?
Flags: needinfo?(tchung)
Flags: needinfo?(hhsu)
(In reply to Miller Medeiros [:millermedeiros] from comment #5)
> Harly and Tony, are you guys happy with current behavior? (on master) Can we
> close this bug?

This works well for me.   Thanks for this!
Flags: needinfo?(tchung)
(In reply to Tony Chung [:tchung] from comment #6)
> (In reply to Miller Medeiros [:millermedeiros] from comment #5)
> > Harly and Tony, are you guys happy with current behavior? (on master) Can we
> > close this bug?
> 
> This works well for me.   Thanks for this!

Yes, this is great! 
I am all thumbs up, thanks!
Flags: needinfo?(hhsu)
this was fixed by the Day View visual refresh patch, so I'm marking it as a duplicate.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 951075
Target Milestone: --- → 2.0 S2 (23may)
Flags: in-moztrap+
[Environment]
Gaia      8d865839d932bfbd5e157f376f74d8cb12bfdd51
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/1d4046a8cb6c
BuildID   20140610000223
Version   32.0a2
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014

[Result]
Pass
Status: RESOLVED → VERIFIED
Whiteboard: [priority]
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.