Download to another disk doesn't work

RESOLVED DUPLICATE of bug 84760

Status

RESOLVED DUPLICATE of bug 84760
17 years ago
14 years ago

People

(Reporter: jakobus, Assigned: colin)

Tracking

Trunk
DEC
OpenVMS

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Downloading a file opens the window "Enter name of file to save to..." If I use
a directory on the disk which has my login directory it's ok, if I selected a
directory on another disk MOZILLA hangs. The process shows a lot of activity and
I've to kill the process.

DEC PWS 500au, OpenVMS 7.3, DECwindows Motif 1.2-6, MOZILLA Build ID: 2001091217
(Assignee)

Comment 1

17 years ago
I fixed this a release or two ago, I wonder what's broken now....
Assignee: asa → colin
(Assignee)

Comment 2

17 years ago
I just tried to reproduce this and can't. I'm specifying a different disk
and it works every time. What am I doing wrong? Is there a "trick" to get
it to fail?
(Reporter)

Comment 3

17 years ago
After selecting a file for download the "Save to" window pops up using the "..."
button I'm going up to the device level and then I'm selecting another disk and
directory. The directory 000000.DIR on the selected disk has the protection
W:RE. The selected directory is on top level and I'm the owner.
(Assignee)

Comment 4

17 years ago
That all sounds normal. I guess we need to find out where its failing. Here's
how it works. It downloads the file to a temporary location in your
SYS$LOGIN directory. Then, once the download is complete, it will rename or
copy the file to the destination you selected (if its the same device it will
rename, otherwise it will copy and then delete). So in your case it will copy
the file to your selected destination. While it is doing this copy the status
dialog shows 100% complete but I believe the CLOSE button is greyed out.

So, when it hangs, is the temporary file present? Has it started to copy the
file yet? Maybe its succeeded in copying and hanging on the delete? Please 
try to determine exactly what the state of these files are at the time of
the hang.

Thanks, Colin.
(Reporter)

Comment 5

17 years ago
I start MOZILLA from a terminal window which is pointing to SYS$LOGIN. Is the
temporary file in SYS$LOGIN or in SYS$SCRATCH? I checked both directories there
aren't files created at the corresponding time. The status window isn't shown so
MOZILLA doesn't start the download. Download to SYS$LOGIN works without
problems. I checked the protection I'm owner of the directory on the other disk
and the file 000000.DIR has the protection W:RE otherwise it's not visible in
the "Save to..." window. 
(Assignee)

Comment 6

17 years ago
SYS$LOGIN and SYS$SCRATCH should both point to the same location.

I'm concerned that you don't get a download status popup. Are you downloading
via HTTP or FTP. What is the URL you are clicking on to invoke the download?

Here's something you can do to get some more info. Edit MOZILLA.COM and find
the line where VMS_TRACE_FILENAMES is defined and UNcomment it (so that it IS
defined). Start Mozilla, you should get some extra output on the DECterm. Once
Mozilla is up and running attempt the download again. Wait for it to fail or
hang or whatever it does. Then mail me the end of the output that's on the 
DECterm. What I usually do is wait until Mozilla is up and running and all the
output has stopped, and then hit CNTL-T a few times to mark in the display 
where I am. Makes it easier to find the start of the "interesting stuff" after
you've exitted Mozilla.
(Reporter)

Comment 7

17 years ago
It doesn't matter if http or ftp.
The trace:
   .
   .
stat_Jacket: Mapped: //iaf021$dka600/ftp/chksum.zip To:
//iaf021$dka600/ftp/chksum.zip
stat_Jacket: Mapped: //iaf021$dka600/ftp/dsnlink_new.zip To:
//iaf021$dka600/ftp/dsnlink_new.zip
stat_Jacket: Mapped: //iaf021$dka600/ftp/files_info.zip To:
//iaf021$dka600/ftp/files_info.zip
stat_Jacket: Mapped: //iaf021$dka600/ftp/flist.zip To: //iaf021$dka600/ftp/flist.zip
stat_Jacket: Mapped: //iaf021$dka600/ftp/httptoip.zip To:
//iaf021$dka600/ftp/httptoip.zip
stat_Jacket: Mapped: //iaf021$dka600/ftp/perf_meter.zip To:
//iaf021$dka600/ftp/perf_meter.zip
stat_Jacket: Mapped: //iaf021$dka600/ftp/sdcl.zip To: //iaf021$dka600/ftp/sdcl.zip
stat_Jacket: Mapped: //iaf021$dka600/ftp/wget-1_5_3g.zip To:
//iaf021$dka600/ftp/wget-1_5_3g.zip
access_Jacket: Mapping: //iaf021$dka600/ftp/CDRECORD-1_11A06.ZIP To:
//iaf021$dka600/ftp/CDRECORD-1_11A06.ZIP
access_Jacket: Mapping: //iaf021$dka600/ftp/CDRECORD-1_11A06.ZIP To:
//iaf021$dka600/ftp/CDRECORD-1_11A06.ZIP
access_Jacket: Mapping: //iaf021$dka600/ftp To: //iaf021$dka600/ftp
access_Jacket: Mapping: //iaf021$dka600/ftp To: //iaf021$dka600/ftp
access_Jacket: Mapping: //iaf021$dka600 To: //iaf021$dka600
access_Jacket: Mapping: / To: /
access_Jacket: Mapping: / To: /
access_Jacket: Mapping: / To: /

This line comes now for ever
(Assignee)

Comment 8

17 years ago
OK, now I know where the problem lies. Its caused by the // at the start 
of the directory name in the "Save File" box. I don't know how you got the
// there but there should only be one /.  

With Mozilla NOT running:
Search your PREFS.JS file (in your _MOZILLA directory which is in your
SYS$LOGIN) for "browser.download.dir". Does the value start with a "//"?
If it does, change the "//" to "/" and you should be all set.

If the above doesn't work, try this:
Get the "Save As" window up. Whatever is in the "Look In" field, type that
into the "File name" field at the bottom, but make sure there is only ONE /
at the start. Hit RETURN. You should now be able to ".." all the way up to
a device list.
(Reporter)

Comment 9

17 years ago
In PREFS.JS is: user_pref("browser.download.dir", "/pl_disk/jakobus");
PL_DISK is a logical device: $ SHOW LOGICAL/FULL PL_DISK
"PL_DISK" [exec] = "IAF021$DKA600:[IAF.PL.]" [concealed,terminal]

In window "Save as" I typed the Look In data: "/pl_disk/jakobus" into the field
"File name" and hit RETURN the field "File name" is now empty. The messages are:
access_Jacket: Mapping: /pl_disk/jakobus To: /pl_disk/jakobus
access_Jacket: Mapping: /pl_disk/jakobus To: /pl_disk/jakobus
stat_Jacket: Mapped: /pl_disk/jakobus To: /pl_disk/jakobus
Now using "..." I changed to another directory on the same disk IAF021$DKA600
opendir_Jacket: Mapped: /pl_disk To: /pl_disk
stat_Jacket: Mapped: /pl_disk/jakobus To: /pl_disk/jakobus
stat_Jacket: Mapped: /pl_disk/jakobus To: /pl_disk/jakobus
opendir_Jacket: Mapped: / To: /
stat_Jacket: Mapped: //iaf021$dka0 To: //iaf021$dka0
stat_Jacket: Mapped: //iaf021$dka600 To: //iaf021$dka600
stat_Jacket: Mapped: //iaf021$dqa0 To: //iaf021$dqa0
stat_Jacket: Mapped: //iaf021$dka0 To: //iaf021$dka0
stat_Jacket: Mapped: //iaf021$dka600 To: //iaf021$dka600
stat_Jacket: Mapped: //iaf021$dqa0 To: //iaf021$dqa0
opendir_Jacket: Mapped: //iaf021$dka600 To: //iaf021$dka600

Next I entered Test into the field "File name". For this the messages are:
access_Jacket: Mapping: //iaf021$dka600/ftp/test To: //iaf021$dka600/ftp/test
access_Jacket: Mapping: //iaf021$dka600/ftp/test To: //iaf021$dka600/ftp/test
access_Jacket: Mapping: //iaf021$dka600/ftp To: //iaf021$dka600/ftp
access_Jacket: Mapping: //iaf021$dka600/ftp To: //iaf021$dka600/ftp
access_Jacket: Mapping: //iaf021$dka600 To: //iaf021$dka600
access_Jacket: Mapping: / To: /
access_Jacket: Mapping: / To: /
(Assignee)

Comment 10

17 years ago
Theo, thanks for the full explanation. I am now able to reproduce the problem
and will look into it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 11

17 years ago
The easy way to reproduce this hang is to just type a slash (/) into the
"File name:" field in the "Save File" dialog.

Theo, I have a new image for you to try. Can you tell me where I can FTP
it to?
(Assignee)

Comment 12

17 years ago
After ".." all the way to the root, when you then select a disk, it appears
in the "look in" field with an extra "/". This is already reported in bug 84760
and is NOT an OpenVMS specific problem.
(Reporter)

Comment 13

17 years ago
Hi Colin!
as I understand you've a solution, send the new image to: ftp.iaf.fhg.de for
testing.
(Assignee)

Comment 14

17 years ago
Can't FTP connect to that address.
(Reporter)

Comment 15

17 years ago
The ftp node is outside of our firewall, the network administrator isn't
inhouse, it's 17:30 :)
I'm able to use ftp "throu" our firewall.
Can I ftp from your site?
(Assignee)

Comment 16

17 years ago
Theo, try this:

ftp to xfer.americas.digital.com and then cd into the to_customer directory.
In there you should find VMS_JACKETS.SO. 

I believe this FTP dropbox is purged every night so if you don't get it today
let me know and I'll recopy tomorrow.

Colin.
(Reporter)

Comment 17

17 years ago
Downloaded vms_jackets.so successfully (set type image was necessary) and
installed it.
I start in "Save to" from my personal SYS$LOGIN which is /pl_disk/jakobus and
moved upwards at the top level "Look in" shows "/".
Now I select the device iaf021$dka600 which is shown in "Look in" as
"//iaf021$dka600"
Save to the directory ftp results in a window:
Title: "Error saving //iaf021$dka600/ftp/mozilla_relnotes.html"
Message: "Path //iaf021$dka600 doesn't exist, can't save
//iaf021$dka600/ftp/mozilla_relnotes.html"
(Assignee)

Comment 18

17 years ago
This last problem may well be caused by the // bug (bug 84760). Can you repeat
the test, only this time, type "/iaf021$dka600/ftp" into the "File name:" field 
and hit RETURN so that "/iaf021$dka600/ftp" (and not "//iaf021$dka600/ftp")
appears in the "Look in:" field. And then type "mozilla_relnotes.html" into
the "File name:" field and hit RETURN. If this works, I believe it proves that
its the // bug that's now biting you.
Status: NEW → ASSIGNED
(Reporter)

Comment 19

17 years ago
I entered /iaf021$dka600/ftp into the field "File name" of window "Save to" and
hit RETURN than I entered mozilla_relnotes.html into the field "File name" and
the download took place.
I've marked this bug as a duplicate of bug 84760.



*** This bug has been marked as a duplicate of 84760 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.