Closed Bug 1003142 Opened 7 years ago Closed 5 years ago

A translucent shadow remains on the page/desktop if alert comes up while dragging

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox30 --- affected
firefox31 --- ?
firefox32 --- affected

People

(Reporter: cbadau, Unassigned)

Details

Attachments

(2 files)

Attached file sample.htm
Reproducible on the latest Nightly (BuildID: 20140429030201) 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Reproducible on the latest Aurora (BuildID: 20140428004000)
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0

Steps to reproduce: 
1. Drag the "sample" html -> an alert comes up (the alert comes up while dragging). 
2. Observe the translucent shadow of the sample being dragged. 

Actual results: The translucent shadow of the sample being dragged remained 'stuck' on the page/desktop. After the alert is dismissed, the translucent shadow disappears. See screenshot "A.png". 

Expected results: No translucent shadow remains on the page/desktop. 

Notes: This is reproducible also on Mac OSX 10.9.
Attached image A.png
Does this also affect Firefox 31?
Which version of Firefox introduced this bug?
Component: General → Layout
Product: Firefox → Core
Not reproducible for Mac OSX 10.8.5 in 31. 
This still needs checking on other platforms/OS for Firefox 31.
This still reproduces on Nightly with e10s disabled, but works fine with e10s enabled. I took a quick look at what the testcase does on older versions and not only was the shadow there (as shown in the screenshot), but I got outright browser hangs as well.

So as far as I can tell, this has been broken for a really long time but works OK in the e10s world. Seems unlikely we're going to spend any engineering effort making the non-e10s case work better, especially since it's not a regression AFAICT, so I'm closing this out as WFM. Feel free to reopen if you feel strongly otherwise.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.